Highlighted
Commander
Commander

CentOS (redhat) e i vmware tools che non partono automaticamente

Jump to solution

ciao a tutti, mi sono accorto che praticamente su tutte le vm centos che ho i tools non partono automaticamente all'avvio.

Ho trovato un post molto esplicativo su cosa accade nelle versioni recenti dei tools ufficiali: in breve gli script di avvio non sono più in /etc/init.d perché usano "Upstart" quindi si trovano in /etc/init e sono sotto forma di file .conf.

le differenze principali sono che non li controlli più con il "service" né appaiono in chkconfig, e i comandi per gestirli sono

NEW Command to check tools: status vmware-tools  
NEW Command to start/stop: start/stop vmware-tools

il problema è che... non funzionano questi controlli, e probabilmente per questo non partono anche automaticamente, come se ci fosse un errore di sintassi nel vmware-tools.conf che riporto sotto

(lanciando a mano  /etc/vmware-tools/services.sh start i tools partono correttamente.)

Ho googlato un po' e ho visto che esiste su Ubuntu un comando per controllare la sintassi (init-checkconf) che però non è presente nella versione di Upstart distribuita con le CentOS 6.x Smiley Sad

Qualcuno ha sperimentato/risolto la cosa?




##########################################################################
# Copyright 2010 VMware, Inc.  All rights reserved. -- VMware Confidential
##########################################################################

##########################################################################
# DO NOT modify this file directly as it will be overwritten the next
# time the VMware Tools are installed.
##########################################################################

description    "VMware Tools services"
author          "VMware, Inc."

# Be sure to block the display managers until our job has completed.  This
# is to make sure our kernel services are running before vmware-user
# may launch.
start on runlevel [235] or starting gdm or starting kdm or starting prefdm
stop on runlevel [06]

pre-start exec /etc/vmware-tools/services.sh start
post-stop exec /etc/vmware-tools/services.sh stop

Alessandro aka Tinto | @tinto1970
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Expert
Expert

Hai provato a rilanciare lo script di riconfigurazione? hai installato da rpm?

lo script è vmware-config-tools.pl (da eseguire come root)

View solution in original post

0 Kudos
13 Replies
Highlighted
Expert
Expert

Hai provato a vedere se i vmware tools sono nell'elenco visualizzato con il comando initctl list?

Prova a modificare il comando di start in questo modo : start on runlevel [2345] (e togli tutto il resto)

e poi prova ad aggiungre il comando respawn subito sotto al comando di stop

Sul guest Centos hai anche l'ambiente grafico o usi solo la console?

Particolari errori nei log?

saluti

Highlighted
Commander
Commander

prima di tutto grazie Smiley Happy
allora, il comando initctl list mi restituisce

>[root@bslin02 ~]# initctl list

>rc stop/waiting

>vmware-tools stop/waiting

in /var/log/messages vedo:

>[root@bslin02 ~]# cat /var/log/messages | grep vmware

>Apr 2 10:25:24 bslin02 init: vmware-tools pre-start process (2094) terminated with status 1

ho l'ambiente grafico installato; ora provo le modifiche che suggerisci

Alessandro aka Tinto | @tinto1970
0 Kudos
Highlighted
Commander
Commander

dopo le modifiche suggerite non pare essere cambiato nulla purtroppo:

>[root@bslin02 ~]# status vmware-tools

>vmware-tools stop/waiting

>[root@bslin02 ~]# start vmware-tools

>start: Job failed to start

>[root@bslin02 ~]# stop vmware-tools

>stop: Unknown instance:

Alessandro aka Tinto | @tinto1970
0 Kudos
Highlighted
Expert
Expert

è il pre-start che fallisce, di conseguenza non va nemmeno lo start Smiley Sad

rimuovi il respawn e rimetti il comando di start di prima.

le mie VM sono senza ambiente grafico, provo a vedere cosa combina il comando di pre-start e ti faccio sapere

0 Kudos
Highlighted
Expert
Expert

verifica a cosa punta il link simbolico /bin/sh

per caso punta alla bash o alla dash?

ls -la /bin/sh

sulle mie VM il link simbolico è questo :

/bin/sh -> bash

se il tuo punta alla dash modificalo per puntare alla bash e poi riprova

fammi sapere

0 Kudos
Highlighted
Commander
Commander

anche da me è

>[root@bslin02 ~]# ls -la /bin/sh

>lrwxrwxrwx 1 root root 4 Jan 14 10:49 /bin/sh -> bash

Alessandro aka Tinto | @tinto1970
0 Kudos
Highlighted
Expert
Expert

se esegui da console il comando : /etc/vmware-tools/services.sh stop e poi /etc/vmware-tools/services.sh start

ti da errori o funziona tutto correttamente?

0 Kudos
Highlighted
Expert
Expert

Per caso hai SELinux abilitato? verifica con il comando sestatus

se è attivo disabilitalo su /etc/selinux/config mettendo a disable

0 Kudos
Highlighted
Commander
Commander

selinux è disabilitato e lanciando manualmente services.sh va tutto perfettamente...

Alessandro aka Tinto | @tinto1970
0 Kudos
Highlighted
Expert
Expert

Hai provato a rilanciare lo script di riconfigurazione? hai installato da rpm?

lo script è vmware-config-tools.pl (da eseguire come root)

View solution in original post

0 Kudos
Highlighted
Commander
Commander

li ho sempre installati montando la iso di quelli "ufficiali" dal vCenter;

ora ho provato a rilanciare lo script e termina con un

initctl: Job failed to start

Unable to start services for VMware Tools

Execution aborted.

la cosa bella è però... che dopo di ciò ho riavviato la macchina e ora pare tutto funzionare come previsto, avvio automatico incluso Smiley Happy

Alessandro aka Tinto | @tinto1970
0 Kudos
Highlighted
Expert
Expert

Mi piace quando non c'è nessuna logica ma alla fine funziona tutto :smileylaugh: ... da brividi

Probabilmente mancava un qualche step

ciao Smiley Happy

0 Kudos
Highlighted
Commander
Commander

è plausibile che il razionale sia questo: facendo gli aggiornamenti automatici non viene rilanciato lo script di config e invece ce ne sarebbe bisogno Smiley Wink

grazie!

Alessandro aka Tinto | @tinto1970
0 Kudos