allo0osh
Contributor
Contributor

mic - microphone problem in linux client

Jump to solution

Hi

I am using vmware horizon client on a linux based Arm device. everything works fine and smooth, but microphone is not redirecting to server.

details:

installed horizon client 2006 and the new version, 2012, on linux and the server is windows 7. I am using alsa sound in linux. I installed the multimedia redirection and RTAV for my client. I enabled mic. when it is not connected to server, "arecored" (for recording sound) and "aplay" (for playing sound) are working fine. I can record and play song with them so the OS does not have a problem with my audio device. when I connect to server, the sound stream is nice, aplay on linux does not work (error: "audio open error : Device or resource busy") and that's fine because the vmware-view is using the sound server and I can play from my windows server and I have the stream. but "arecord" works. means that vmware-view is not using the microphone, and is not redirecting the mic to the server.

for test, I installed vmware horizon client on a linux mint 20 both with ".bundle file" and "tar archive" on my laptop, and no difference. mic is not working on windows server. and the mic is working fine inside the linux mint.

for another test, installed vmware horizon client on a windows 10 on another laptop, and microphone works nice and smooth on the server. so I assumed this is not a problem with my server and its dependencies or restrictions or policies.

does anyone know how to solve this problem?

 

ps:

uname -a in arm device: "Linux zcopipc 5.9.12-sunxi #trunk SMP Fri Dec 4 17:16:00 +0330 2020 armv7l GNU/Linux"
uname -a in laptop: "Linux mard 5.4.0-59-generic #65-Ubuntu SMP Thu Dec 10 12:01:51 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux"

 

0 Kudos
1 Solution

Accepted Solutions
Albertovich
Enthusiast
Enthusiast

Sorry, the workarround work for me on my arm devices (raspberry pi 3/4) with no audio input.

So we put the USB sound cards on raspberrys and change/create the /etc/vmware/config file.

Vmware don't redirect any audio or video at all on an ARM device so you have 3 options:

1.- Try the workarround i proposed (USB sound card with redirection and deal with low quality)

2.- Wait for vmware to add RTAV support on ARM.

3.- Write your own solution. 

Regards

View solution in original post

11 Replies
ofox
VMware Employee
VMware Employee

Hi  allo0osh,

RTAV on Horizon Linux client does not yet support arm device.

allo0osh
Contributor
Contributor

Thanks. that's a sad thing to hear by the way

but why audio output streaming is working fine?

forgot to say that: I am using PCOIP protocol

0 Kudos
ofox
VMware Employee
VMware Employee
Audio output uses a different technology than RTAV, thus not part of RTAV.
ofox
VMware Employee
VMware Employee

RTAV aims to support audio input and video input devices, typically they are microphones and webcams.

allo0osh
Contributor
Contributor

Thank you

0 Kudos
Albertovich
Enthusiast
Enthusiast

Hi

This is a workarround for your issue, it works(degradate) for me on raspberry clients.

I'm hope vmware release RTAV suppor on ARM someday 😉

Edit or create /etc/vmware/config

add or uncomment this 2 lines:

viewusb.AllowAudioIn=TRUE

viewusb.AllowAudioIn=TRUE

 

This overrides usb audio redirection directive so you should see your usb audio device 

working in the virtual desktop.

Audio quality should be pretty poor but at least enought to get a skype or zoom call.

This only work if connection is fast, you should not get enought sound quality in slow networks.

 

good luck. 

Albertovich
Enthusiast
Enthusiast

Should Vmware support RTAV on arm in the future?

0 Kudos
ofox
VMware Employee
VMware Employee

Yes it's been on the roadmap for a while. We'll try to get that but I can not say a word now on when. Suggest you guys also to speak with your VMware contact if possible.

0 Kudos
allo0osh
Contributor
Contributor

thanks a lot but I don't have "/etc/vmware/config" file. and my mics are not USB. do they have to be USB mics for this solution?

the result of this search "find / | grep vmware | grep config"

is "/usr/lib/vmware-installer-horizon/2.1.0/bin/configure-initscript.sh" so if I create the file, would it be OK?

I am currently working on a solution to send microphone audio to the windows through network, and create a virtual line in audio device in windows so I can use network audio as a line in mic. do you have a hint or suggestion for that?

Albertovich
Enthusiast
Enthusiast

Sorry, the workarround work for me on my arm devices (raspberry pi 3/4) with no audio input.

So we put the USB sound cards on raspberrys and change/create the /etc/vmware/config file.

Vmware don't redirect any audio or video at all on an ARM device so you have 3 options:

1.- Try the workarround i proposed (USB sound card with redirection and deal with low quality)

2.- Wait for vmware to add RTAV support on ARM.

3.- Write your own solution. 

Regards

View solution in original post

allo0osh
Contributor
Contributor

Thanks a lot

0 Kudos