ObiWoRen
Contributor
Contributor

Ubuntu 18.04 / gdm3 no SSO, Text input Field Does Not Update

Jump to solution

My configuration boils down to Linux VMs running Ubuntu 18.04 LTS with Horizon Agent 7.12.0 being viewed remotely by the Horizon Client 5.4.2.

When the Horizon Client connects, the gdm3 login screen displays, but only updates when the mouse is used to open a menu. Simply typing in to the username / password field causes no obvious graphical changes. But, if you right-click on the input field or click on the power drop-down menu, the username / password field reflects the text that was typed. If the accessibility menu is used to enable 'zoom', the field updates as expected. So, at least there is a work-a-round.

Everything else about the sessions are nominal. Once a user has logged in and started either a Gnome 3 or a MATE session, everything behaves and redraws as expected. This only impacts the gdm3 login screen.

Has anyone else experienced this behavior?

1 Solution

Accepted Solutions
songkai
VMware Employee
VMware Employee

Hi ObiWoRen

Thanks your for your information! This bug should be fix in Horizon 8 release. It is looks like gnome-shell of greeter mode in ubuntu 18,04 doesn't work well with the remote display env such as DISPLAY=127.0.0.1:100.  A workaround for this issue is to export a short DISPLAY value such as DISPLAY=:100 for gnome-shell greeter. You can warp the gnome-shell program as following:

1) create a new file /usr/bin/gnome-shell-warp.sh with following context:

#!/bin/sh

export DISPLAY=:${DISPLAY##*:}

exec /usr/bin/gnome-shell

2) chmod 755 /usr/bin/gnome-shell-warp.sh

3) Modify file /usr/share/applications/org.gnome.Shell.desktop, use

"Exec=/usr/bin/gnome-shell-warper.sh"

instead of

"Exec=/usr/bin/gnome-shell"

Best Regards

Kai

View solution in original post

6 Replies
PomAbroad
Contributor
Contributor

I have confirmed this is a known issue with the GDM3 greeter ui.  The workaround is to have a window size at or smaller that 800x600, then the screen refreshes as expected.  Any higher than that it doesn't work.  VMWare say this is an Gnome issue not a VMWare agent issue.

0 Kudos
ObiWoRen
Contributor
Contributor

Interesting. Do you have a source for this PomAbroad​ ? Possibly a bug report in the upstream gdm3 repository?

0 Kudos
PomAbroad
Contributor
Contributor

Yes I do, I have a case closed with VMWare:

Hi Kevin,

Thank you for your time earlier on the remote session.

I have researched further with our development team and this is a reported known issue with Ubuntu when SSO is disabled.

Feedback from our developer for this issue as follow:

This is a gnome-shell issue. When the width resolution of desktop more than 800, the greeter UI may can't display the text input in the screen, but these inputs is valid for login. The workaround is customer keep the resolution less than 800x600 in login greeter screen if sso disable.

Thank you.

Kind Regards,

********

Technical Support Engineer

Global Support Services, VMware Inc.

My Hours: 9:00 AM – 5:30 PM (AEST)

Phone: 1800 040 235 (Australia)

0 Kudos
ObiWoRen
Contributor
Contributor

I am not sure that I can agree with VMware's assessment that this is only a gnome-shell issue.

I have two classes of Ubuntu 18.04 LTS VMs. They are configured nearly identically, except that about half of them are backed by NVIDIA Tesla P40 GPUs. (They use the 'nvidia' driver in the guest OS) On the hardware-backed VMs, there are no refresh issues with the gdm3 login screen at 1920x1200.

0 Kudos
songkai
VMware Employee
VMware Employee

Hi ObiWoRen

Thanks your for your information! This bug should be fix in Horizon 8 release. It is looks like gnome-shell of greeter mode in ubuntu 18,04 doesn't work well with the remote display env such as DISPLAY=127.0.0.1:100.  A workaround for this issue is to export a short DISPLAY value such as DISPLAY=:100 for gnome-shell greeter. You can warp the gnome-shell program as following:

1) create a new file /usr/bin/gnome-shell-warp.sh with following context:

#!/bin/sh

export DISPLAY=:${DISPLAY##*:}

exec /usr/bin/gnome-shell

2) chmod 755 /usr/bin/gnome-shell-warp.sh

3) Modify file /usr/share/applications/org.gnome.Shell.desktop, use

"Exec=/usr/bin/gnome-shell-warper.sh"

instead of

"Exec=/usr/bin/gnome-shell"

Best Regards

Kai

View solution in original post

ObiWoRen
Contributor
Contributor

Thank you songkai​, that workaround does resolve the issue! I will mark your post as being the correct answer.

PomAbroad​, tagging you so that you see this post.