einstein-a-go-g
Hot Shot
Hot Shot

Physical Linux Desktops - possible or not ?

is there any method to configure the Linux Agent to communicate with the broker, so physical Linux machines can be used with Horizon like Windows.

Virtual Linux VMs work a treat, BUT I need physical GPUs, and have a warehouse of physical machines we would like to deploy for Horizon access for a CAD type application, because VMs are too slow, at 4fps under simulation.

0 Kudos
13 Replies
Perttu
Enthusiast
Enthusiast

Hi, 

I don't see any reason why this would not work at least if you install the Agent in multi-session configuration, i.e. with --multiple-session parameter. In this configuration mode the Agent registers itself to a broker and I wonder what exactly would prohibit it taking in sessions even it runs on a physical hardware instead of a virtual one.

In other words, if you have an unmanaged virtual machine or an unmanaged physical machine, what difference there is from Agent's point of view? The Agent just sees the Linux box, not what is behind it.       

einstein-a-go-g
Hot Shot
Hot Shot

Just to follow up, after debugging and viewing the installer, we found the correct syntax to use, and debugging the logs

although it also states in the Installer "Internal Use Only" and not officially supported.

It does what we need it to do, one of the requirements is to install Open-vm-tools-desktop, although not a VM!

Thanks

Andy

0 Kudos
sappomannoz
Hot Shot
Hot Shot

Hello, sorry to hi-jack this post @Perttu.

 

If I understand correctly you are suggesting to use the un-managed mode of the multiple-session agent.

If I try to install it with this command, no matter if on a VM or a physical machine:

install_viewagent.sh --multiple-session -M no -A yes

like it's described in the documentation, I always get this error:

Horizon Connection Server not specified

the issue  here is, there is no way in the documentation to specify the connection server.

 

0 Kudos
Perttu
Enthusiast
Enthusiast

Hi,

That's perfectly okay. So try this:

./install_viewagent.sh --multiple-session -M no -A yes -b <broker fqdn> -d <domain fqdn> -u <username with horizon admin rights>

like 

./install_viewagent.sh --multiple-session -M no -A yes -b connectionserver1.contoso.com -d contoso.com -u johndoe

0 Kudos
sappomannoz
Hot Shot
Hot Shot

Thanks for the update. It would be nice for VMware to update their documentation and document the missing parameters. 

0 Kudos
einstein-a-go-g
Hot Shot
Hot Shot

if you look through the script, you can find all the switches required!

if you Google enough you can eventually find them all.

But again, it's for Internal usage and not officially supported!

0 Kudos
sappomannoz
Hot Shot
Hot Shot

Hi @einstein-a-go-g ,

it's unsupported on a physical machine but it should be supported on a VM. From the official documentation:

Create a Manual Farm of Linux Virtual Machines

https://docs.vmware.com/en/VMware-Horizon/2111/linux-desktops-setup/GUID-92110540-8170-49C3-A150-F9C...

  • Verify that you have installed Horizon Agent on each host machine with the --multiple-sessionparameter included and the managed agent -M parameter set to no. For example:
     
    sudo ./install_viewagent.sh --multiple-session -M no

But if I try to run the installer on a VM without the undocumented parameters the installation fails complaining that the connection server parameter is missing. This makes sense, since also under Windows I must specify credentials and the connection server address. How should the agent magically know where to connect!

I'm wondering if my setup is somehow wrong or if the documentation is incomplete 🤔.

Tags (1)
0 Kudos
einstein-a-go-g
Hot Shot
Hot Shot

do you still have issues ?

we have it working on VMs and physical machines, and we have managed and unmanged.

this is for VMs (not managed by vCenter Server) and Physical Workstations

we use the following

sudo ./install_viewagent.sh -M no -b connectioin-server.domain.name -d active-directory.domain.name -u Active Directory username

 

0 Kudos
sappomannoz
Hot Shot
Hot Shot

Hi @einstein-a-go-g ,

yes, I have issues with non-managed RDS VMs that are getting unreachable. See my new post:

https://communities.vmware.com/t5/Horizon-for-Linux/Issues-with-a-non-managed-RDS-Linux-Pool/m-p/288...

I see you are installing the agent on non-managed VMs using the unsupported/unofficial parameters. Have you tried by following the official Horizon documentation where just  -M no ----multiple-session. Or are you using the non-managed VMs in singleton mode?

 

0 Kudos
einstein-a-go-g
Hot Shot
Hot Shot

non-managed "VMs in singleton mode"

could you expand on that ?

0 Kudos
sappomannoz
Hot Shot
Hot Shot

singleton mode, it's called that way in the source of the installer. it's when you don't use the multiple-session feature. So the plain VDI mode when you are not using RDS features.

0 Kudos
einstein-a-go-g
Hot Shot
Hot Shot

the method which works for us, is in the command above, because we have VMs hosted on another platform, in different domain and hosts to the VDI connection server.

also we have physical desktops, in the same domain as the connection server, because we just wanted to use the "real estate inventory" at this time, and people are working from home, still because of COVID-19.

So it's a 1-1 relationship in terms of allocation.

0 Kudos
sappomannoz
Hot Shot
Hot Shot

Hi @einstein-a-go-g , got it. Thanks

0 Kudos