Perttu
Enthusiast
Enthusiast

Horizon Agent for Linux issues with Ubuntu 20.04 and how to increase logging verbosity

Jump to solution

Hi all,

I'm having session connecting trouble with Ubuntu 20.04. For some reason it doesn't work like it does with Ubuntu 18.04. Due to terse logging I'm unable to get a grip to what actually happens in the login process. Here are few log excerpts.

--- Ubuntu 20.04 ---

2021-02-16T16:54:42.502Z INFO <pool-2-thread-1> [DesktopHandler] [DesktopID: 2] Start session for user: luser
2021-02-16T16:54:42.502Z INFO <pool-2-thread-1> [DesktopHandler] [DesktopID: 2] Creating new session for user:luser
2021-02-16T16:54:42.521Z INFO <pool-2-thread-1> [DesktopHandler] [DesktopID: 2] Session for user: luser, have SSO cred: true
2021-02-16T16:54:42.987Z INFO <Thread-3> [DesktopDaemonIPCHandler] DesktopDaemonIPCHandler get IPC message
2021-02-16T16:54:42.988Z DEBUG <Thread-3> [DesktopManager] [DesktopID: 2] Handle IPC event
2021-02-16T16:54:42.989Z DEBUG <pool-2-thread-1> [DesktopHandler] [DesktopID: 2] Submit event task
2021-02-16T16:54:42.989Z DEBUG <pool-2-thread-1> [DesktopHandler] [DesktopID: 2] Process desktop daemon ipc event: DesktopDestroyed

^ This is an alarming line and I would like to know more about it. Why the Desktop is being destroyed?
2021-02-16T16:54:42.989Z DEBUG <pool-2-thread-1> [DesktopHandler] [DesktopID: 2] Desktop was destroyed now.
2021-02-16T16:54:42.989Z DEBUG <pool-2-thread-1> [IpcConnectionMgr] Clean up magic for client 2, magic is 3e61d-***-727ce
2021-02-16T16:54:42.990Z DEBUG <pool-2-thread-1> [DesktopManager] [DesktopID: 2] Sending session end event for desktop, SID: s-1-5-***-24345 Domain: TESTTEST User: luser SessionType: DESKTOP
2021-02-16T16:54:42.990Z INFO <pool-2-thread-1> [StandaloneAgent] -----SVI State: false USE SVI: false
2021-02-16T16:54:42.990Z DEBUG <pool-2-thread-1> [ComponentResponse] Message is ENDED
2021-02-16T16:54:42.990Z DEBUG <pool-2-thread-1> [JMSHandler] Sending event: AGENT_ENDED
2021-02-16T16:54:42.992Z DEBUG <pool-4-thread-3> [EventPublishingManager] Checking for message to publish.
2021-02-16T16:54:42.993Z INFO <Thread-3> [BlastIPCHandler] BlastIPCHandler get IPC message
2021-02-16T16:54:42.995Z DEBUG <pool-5-thread-4> [AbstractTopicPublishingManager] Message published.
2021-02-16T16:54:42.996Z ERROR <Thread-3> [DesktopManager] [DesktopID: 2] Failed to handle the ipc event, the desktop doesn't exist
... and session never establishes

--- Ubuntu 18.04 ---

2021-02-16T16:51:49.831Z INFO <pool-2-thread-1> [DesktopHandler] [DesktopID: 1] Start session for user: luser
2021-02-16T16:51:49.831Z INFO <pool-2-thread-1> [DesktopHandler] [DesktopID: 1] Creating new session for user:luser
2021-02-16T16:51:49.851Z INFO <pool-2-thread-1> [DesktopHandler] [DesktopID: 1] Session for user: luser, have SSO cred: true
2021-02-16T16:51:50.473Z INFO <Thread-3> [BlastIPCHandler] BlastIPCHandler get IPC message
2021-02-16T16:51:50.476Z DEBUG <Thread-3> [DesktopManager] [DesktopID: 1] Handle IPC event
2021-02-16T16:51:50.476Z DEBUG <pool-2-thread-1> [DesktopHandler] [DesktopID: 1] Submit event task
2021-02-16T16:51:50.476Z DEBUG <pool-2-thread-1> [DesktopHandler] [DesktopID: 1] Process blast server ipc event: SessionReady
2021-02-16T16:51:50.477Z INFO <pool-2-thread-1> [DesktopHandler] [DesktopID: 1] Session is ready now
2021-02-16T16:51:50.479Z DEBUG <pool-2-thread-1> [SessionTimer] starting PENDING_SESSION timer 1 for vdi-machine-034
2021-02-16T16:51:50.481Z DEBUG <pool-2-thread-1> [DesktopHandler] [DesktopID: 1] Complete request task 1
... and everything goes as expected

I suppose I should file a GSS, but let's try this way first.

0 Kudos
1 Solution

Accepted Solutions
Perttu
Enthusiast
Enthusiast

Hi again,

Actually I was able to resolve this. An another script had overwritten contents in /etc/gdm3/custom.conf.

WaylandEnable had to be false and xdmcp enabled.

 

View solution in original post

0 Kudos
1 Reply
Perttu
Enthusiast
Enthusiast

Hi again,

Actually I was able to resolve this. An another script had overwritten contents in /etc/gdm3/custom.conf.

WaylandEnable had to be false and xdmcp enabled.

 

View solution in original post

0 Kudos