Highlighted
Contributor
Contributor

All available desktop sources for this desktop are currently busy

Hi all,

I'm working on configuring a RHEL 7 desktop that leverages an nVidia Grid GPU. When I try to connect to the VM through Horizon I receive the following error message:

"Error - All available desktop sources for this desktop are currently busy. Please try connecting to this desktop again later, or contact your system administrator"

I've tried the following:

  • Resetting the VM via Horizon
  • Placing the VM into maintenance mode in Horizon causes the error message to change to no desktops available instead of "busy".
  • Verified Horizon entitlements
  • Removing the VM from the Pool and re-adding
  • Verified the VM status is Available within the pool
  • Verified no sessions to the VM
  • Tried from Horizon HTML and fat client
  • Verified Pool and Client were set to Blast

The RHEL 7 VM boots and the GUI seems to "half boot". At the VM console It shows the RHEL 7 wallpaper but never presents the login box. I'm not sure if this is expected behavior or if this could be the cause of Horizon seeing the VM as "busy".

VM Configuration

  • All memory fully reserved
  • RHEL 7 VM w/ Shared Direct Tesla M10 GPU
  • nVidia driver (418.130) successfully installed on ESXi host and RHEL 7 VM
    • nvidia-smi works on both the ESXi host and VM and shows the M10
  • Blacklisted nouveau driver in the grub file and the blacklist file
  • Re-created initramfs
  • Updated xorg.conf
  • Installed the Horizon agent (7.10) and pointed it to the broker

Environment

  • ESXi 6.5
  • Horizon 7.10
  • RHEL 7
  • nVidia Tesla M10
    • Shared direct
    • M10-8q profile

Any ideas?

Thanks!

Tags (1)
0 Kudos
8 Replies
Highlighted
Hot Shot
Hot Shot

Hi,

Are you able to do an SSH connection to one of the VDI Desktops using puTTY tool (port 22) using root credential? This is just to check if you can access your RHEL VDI outside of Horizon.

Did you try to remove the Graphics driver and then remove the GPU Card from VM Settings to check if you can access the VDI from Horizon Clent/HML Client?

/Jon

0 Kudos
Highlighted
Contributor
Contributor

Hi Jon,

I am able to successfully SSH to the VDI desktop using root. I haven't tried your removing the vGPU yet because it requires quite a bit of work to remove it and then reconfigure RHEL 7 back to the nouveau driver. I'm worried that I will break something else in the process but I'm thinking I might have to head in that direction...

Thanks,

-Jay

0 Kudos
Highlighted
Hot Shot
Hot Shot

Hi Kay,

Could you upload the below log in one of the Linux Desktops?

/usr/lib/vmware/viewagent/viewagent-debug.log

/Jon

0 Kudos
Highlighted
Contributor
Contributor

Hey Jon,

I'm limited in what I can upload but I checked and there are no debug logs in that folder...

Thanks.

0 Kudos
Highlighted
Hot Shot
Hot Shot

View Agent logs for Linux

Horizon Agent installation directory /usr/lib/vmware/viewagent

Logs /var/log/vmware/

Horizon Agent configuration /etc/vmware/viewagent-config.txt

Machine configuration /etc/vmware/viewagent-machine.cfg

Blast Server /tmp/vmware-root/vmware-mks-<pid>.log

Please check the view agent logs from the above location.

0 Kudos
Highlighted
Contributor
Contributor

Hey Jon - Thanks for providing those locations. Unfortunately, the debug log wasn't providing any details but I was able to track down the issue. The desktop I was connecting to via Horizon is a Linux desktop with an nVidia GPU. Well, unfortunately, it looks like X Server was crashing at startup and Horizon relies on X Server. Without X Server there was essentially no GUI for Horizon to connect to hence the error message that all available desktop sources for this desktop are currently busy.

Thanks again for your help!

-Jay

0 Kudos
Highlighted
Contributor
Contributor

Hi Jay,

Do u manage to resolve your x server issue and get your linux desktop connected?

0 Kudos
Highlighted
Contributor
Contributor

Hey - My issue revolved around the xorg.conf file which I was able to fix by using the following command to generate the xorg.conf file:

sudo nvidia-xconfig --busid="PCI:2:2:0" --allow-empty-initial-configuration

The part I was missing was the --allow-empty-initial-configuration switch. Obviously you have to replace the PCI address with your cards PCI address. I've also seen this error be caused by FIPS mode being enabled in RHEL.

Here are a few guides I put together:

nVidia vGPU Guide - Linux (CentOS 7.7) - Nervous Admin

nVidia vGPU Guide – Linux (CentOS 😎 - Nervous Admin

-Jay

0 Kudos