rak
Contributor
Contributor

usb redirection of smart card reader not working in Windows 10

I'm trying to get my HID OmniKey smart card reader to get redirected into my VDI with the 3.5 View agent. I read the articles about adding registry keys to allow the vid/pid pair in and did that. But it still doesn't work. The reader seems to work on Windows 7. But I'm using a Surface Book with Windows 10. It also fails with Windows 10 on a Samsung laptop. It could be also related to USB 3. I think my book has only USB 3 port.

I did verify that I see the reader in the device manager of my laptop. So it's there for sure. But the View app doesn't pick it up.

Any help would be greatly appreciated.

0 Kudos
3 Replies
chengs
VMware Employee
VMware Employee

You can use GPO templates vdm_client.adm and vdm_agent.adm (download them from official website) instead of registry key. To enable the smart card, just set IncludeVidPid on client or agent side. For more information, please refer to http://www.vmware.com/files/pdf/techpaper/vmware-horizon-view-usb-device-redirection.pdf.

Let me know if any further questions.

0 Kudos
rak
Contributor
Contributor

I had to set AllowSmartCard = true in the registry and then it worked. The trick was that most VMWare documents refer to this registry key as AllowSmartcards (plural). But that will not work. The name has to be singular.

0 Kudos
rak
Contributor
Contributor

Nice document. It references AllowSmartcard and not AllowSmartcards.

I also try to get this to work on a Fedora Core 21 Linux. The document talks a little bit about Linux but not much. What is the trick to get it to work there? The startup scripts references vmware-view-usb but this script or binary didn't get installed. I just got vmware-view-usbd. I enabled usb redirection in /etc/vmware/config and started the arbitrator and usbd service. But I still don't get my smart reader on my VDI.

Any ideas?

0 Kudos