ianchristopher
Contributor
Contributor

reverting optimization tool's background personalization settings

I've created a golden image for Windows 10 1809 that I've spend a lot of time configuring and i'm 99% happy with, but a setting was applied by the optimization tool (v B1140) to set the desktop background to a solid color. Even though I specified "allow users to change background" ... I'm now having issues applying BGinfo image as background on VMs created from this desktop. If you right click on the desktop and try to personalize, you get the message "some settings are hidden or managed by your organization" .. even as a administrator.

Anyone know how I can revert this setting to allow BGinfo background image to be applied.

I've tried re-running the OSOT without the settings checked (no luck)

I've tried setting the registry key at HKCU\software\microsoft\windows\currentversion\policies\activedesktop\NoChangingWallPaper to 0 and deleting the key all together

I've tried setting the GPO at User Configuration > admin templates > Control Panel > Personlization > Prevent Changing Wall Paper to disabled

Nothing seems to have any affect. Anyone know how to reverse this setting?

7 Replies
RoderikdeBlock
Enthusiast
Enthusiast

I have created a logon task (using DEM) which applied BGINFO.

Command:

"%ProgramFiles(x86)%\MICROSOFT-BGINFO\Bginfo64.exe" "%ProgramFiles(x86)%\MICROSOFT-BGINFO\Custom-Background.bgi" /timer:0 /silent /nolicprompt

Roderik de Block


Blog: https://roderikdeblock.com
ianchristopher
Contributor
Contributor

Thanks, that'll be helpful once I get DEM setup.

The issue was still that the gold image created with OSOT had the background locked down. In case anyone else runs into this issue, the following actions reverted this setting :

Edit the local group policy -

User Configuration > Administrative Templates > Desktop > Enable Active Desktop = Enabled

User Configuration > Administrative Templates > Desktop > Prohibit Changes = Disabled

User Configuration > Administrative Templates > Desktop > Desktop Wallpaper = Disabled

User Configuration > Administrative Templates > Control Panel > Personalization > Prevent changing desktop background = Disabled

I'm not sure if it's all or none, but this combination of settings wiped out what ever settings were applied by OSOT to lock down the background and enabled BGInfo to apply the correct background image.

jooji_marsh
Enthusiast
Enthusiast

Ahhhhh thats where it is, thank you so much I'm going down the exact same path you are i'll try this tomorrow, literally the only thing bugging me and its so menial! Its weird why they put that in the optimisation guide. How much more optimized does a solid background colour make the VM!

0 Kudos
GTO455
Enthusiast
Enthusiast

Thank you for this. It was driving me nuts as well!

0 Kudos
MaxStr
Enthusiast
Enthusiast

Thanks. Would be great if the optimization tool had the option to toggle individual settings on or off, rather than undo the entire thing

0 Kudos
onfire247
Enthusiast
Enthusiast

None of the above group policy keys were toggled (or even existed) for me. If you find yourself in the same position, you can find the setting in the registry here:

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System]
"Wallpaper"=""

Export the System key to the desktop, and then delete that "Wallpaper" REG_SZ.

You should now be able to access the background personalization fields.

Personally, I keep this setting to increase VM performance, and make individual changes if people complain. Your mileage may vary in your environment, however.

GreyPotato
Contributor
Contributor

You sir are the real hero.  Nixing the Wallpaper=" " Reg_SZ fixed my issue.

This helped too:

https://kb.vmware.com/s/article/2100962