Enthusiast
Enthusiast

Zoom issues using VDI with Remote Thin Clients and UAG's

Hello,

Looking for some assistance on using Zoom in our VDI environment, mostly for users logging in remotely using Dell thin clients (and UAG's for authentication). We are using VDI with PCoIP in our environment.

If I log in remotely using a thin client, authenticate through the UAG's, get assigned a desktop and fire up Zoom, the experience is horrible, and basically unusable. Audio and video is choppy and frequently freezes up. VDI resources are not an issue, CPU/RAM/GPU are all under 50% utilized with Zoom running. All other apps work fine.

However, if I connect to our corporate network using a laptop with a traditional VPN, and use the Horizon Client to connect to the same pool, Zoom works MUCH better in VDI.

I understand that it should be better over the VPN because of dedicated resources vs. shared, but the difference is night/day.

Made some typical optimizations and other registry changes to the VDI image to for situations where high latency could be an issue, but that has not made a difference.

UAG's are behind the corporate firewall and F5 load balancers, and the only ports open for remote connectivity are 443 and 4172 (PCoIP). Connection servers on the internal network are also behind a F5 load balancer.

VDI image has all the latest updates and agents, and all applications are local, no AppStacks involved.

Environmental Specs

  • Horizon 7.10 ESB
  • DEM 9.9
  • Instant Clones
  • Windows 10 1909 (Ent.) 4 CPU/10 GB RAM/ 75GB Disk 
  • NVidia M10 (1GB Profile per user)
  • Zoom Client for VDI (5.4.58716)
  • Zoom Plugin for VMWare Horizon (5.4.58714)
  • Dell 5470 Thin Clients
  • UAG 20.09

Other than Zoom, the environment with the remote thin clients and UAG's work great, but my boss considers this Zoom issue a "showstopper" and is hesitant to release this service to our users until this is resolved.

I know there are a lot of moving parts to this environment, but I am hoping someone else has run into this same or similar issue and can offer some suggestions!

Thanks!

C

 

Labels (4)
Tags (4)
0 Kudos
26 Replies
Enthusiast
Enthusiast

You say that when you connect via UAG with thin client, Zoom performance is bad and when you connect via a laptop with VPN to the virtual desktops (I assume you are pointing the Horizon Client on your laptop directly at a connection broker server) performance is good.

What happens if you point the Horizon client on the laptop to the UAG and connect that way (no VPN).  Is the performance good or bad?

Enthusiast
Enthusiast

Why the hell didn't I think of that?  😁

Actually, I did, but due to company policy, we aren't supposed to do that. However, for the greater good I tried it last night, and it works well.

So I guess it comes down to the thin clients being the issue, specifically I think it is Wyse ThinOS. Unfortunately, I cannot find anything about plugins, optimizations or enhancements for Zoom using ThinOS.

Is anyone else using Dell-Wyse thin clients with ThinOS and Zoom?

I guess a call into Dell is in order. However, given past experience, I'm not holding out much hope.


Thanks!

0 Kudos
VMware Employee
VMware Employee

It's narrowing down to ThinOS thin client, while I guess you could also give e.g. Teams, Webex a try on the thin lcient setup, to see if they make any difference.

0 Kudos
Contributor
Contributor

Just wanna chime in, we have the same experience as the OP.

We're running Dell Wyse 5070 Thin Clients with the latest 8.6.511 ThinOS (Can't run 9 as that's Citrix only).  We're running Horizon 7.10.3 ESB but Windows 10 1809.

We're utilizing NVIDIA vGPU 8.5 as well with Blast and H264 acceleration, but we have 2GB frame buffers per user and not 1GB.

Whether using Zoom fat or Zoom VDI, Zoom performance is trash.

I mean, it works but it will randomly freeze the video of the entire session and users will need to power cycle their thin client or use the CTRL+ALT+DOWN combination to quickly disconnect and reconnect to get back into Zoom.

We're properly redirecting the webcam and everything has been set up correctly, but it still runs pretty poorly.

We're going to try to upgrade the NVIDIA driver to 11.2 later tonight to see if that helps at all, but we might be looking at purchasing some new thin clients that run Windows 10 IoT vs Dell's ThinOS so we can be running the latest and greatest Horizon client, plus proper Zoom plugin, and have some decent performance.

In this time especially, we are having a lot of virtual meetings and if this really is a Dell problem, their device and software is not up to snuff!

Edit: Also, to the OP, the Zoom plugin has to be installed on the thin client and not the host.  The host VM only needs the Zoom VDI client.  As it is, you CANNOT install the Zoom plugin on the Dell ThinOS thin client as there is no version that supports Dell ThinOS.  Only Windows, IGEL and HP thin clients.  There is no Zoom plugin for Dell ThinOS.

0 Kudos
Enthusiast
Enthusiast

When you are setting up your Zoom session, what are you selecting for your webcam and microphone devices?  Hopefully VMWare Virtual Webcam and VMWare Virtual Microphone.

0 Kudos
Enthusiast
Enthusiast

My understanding is that if you're attempting to use zero clients (PCoIP) and zoom you are not going to have any luck with ZoomVideo. Video requires the use of RTAV and PCoIP and as far as i know PCoIP does not work with that. You need to utilize the BLAST protocol and Thin clients. View Software clients will also work with Zoom as they use Blast. Anyone can correct me if I'm wrong as I am attempting to come up with a better video experience for our WFH users who are currently on PCoIP zero clients. We will probably be updating to Thin clients\Blast\RTAV etc. Working with Zoom and no Video is OK and that is currently how we are running.

 

0 Kudos
Enthusiast
Enthusiast

@VMVSF ,

Thanks for relaying your experience and validating the issues.

We're using the new 5470 line of mobile and AIO thin clients running 8.6_412 of ThinOS, but we have 5070's internally and I can confirm the same experience with those as well. If you are using BLAST as opposed PCoIP, it just reaffirms that this issue has something to do with the thin clients and/or ThinOS.

I even tried playing with the video settings in the thin client and it made no difference. I did find in the Dell documentation that recommends using the Logitech C930e for the 5470 line of thin clients because of their ability to perform hardware encoding, so I have one of those on order to test. I also have on order a 5470 laptop with an integrated web cam to see if that make a difference as well. I will report back on my findings. The cam should be here next week, but no idea on the other 5470.

I would be interested to find out if the upgraded NVidia driver works for you. I tried messing around with the Nvidia Desktop Manager in the VDI session, but again it made no difference for us.

As @jmacdaddy, suggested, I did bypass the thin clients and used my laptop to hold a zoom meeting through the UAG's. The difference using my laptop over using the thin client was much better, although the video on my laptop was a bit pixelated, there was no freezing, or major video delays.

Thanks for the info on the Zoom plugin. I did read that but I figured installing it on the VDI image was better than nothing!

I think I will call Dell and see if they can come up with something to offer.

 

Thanks,

C

0 Kudos
Enthusiast
Enthusiast

I just wanted to report back that after ordering the camera Dell suggests in their documentation (Logitech C930e), it made no difference in the quality of a Zoom session.

@VMVSF -Did you have any luck with the NVidia drivers?

0 Kudos
Contributor
Contributor

We are also having Zoom call issues with 5070 thin clients.  The issue appears to be the lack of a Zoom VDI client for ThinOS in our case.  We're waiting for ThinOS 9.1 to come out shortly.  This should have the latest Zoom client which will handle the RTAV optimizations for Zoom calls.  Zoom calls to the same Horizon VDI via a Windows client that has the Zoom client installed works well. This confirms the Thin client OS is lacking the Zoom optimizations.

0 Kudos
Enthusiast
Enthusiast

The new firmware has been released and there is a separate installer for the Zoom optimization app.  However, we have noted that they have removed the webcam settings from the Peripherals menu.  You can select the webcam you want to use - and that's it.  All the other customizable options are gone.  We have noticed that webcam performance is bad in the new version 9.1.1 firmware, similar to having the Optimize for CPU option enabled in 8.6_606 and older version.

Seems like we just can't have it all.

0 Kudos
Enthusiast
Enthusiast

Thanks for letting me know. What version of Horizon are you using?

 

In your opinion, is it even worth the trouble of updating?

0 Kudos
Contributor
Contributor

The Zoom VDI Plug-in built into ThinOS 9.1 is version 3.3.2  (5.4.59208.1207) so you need to have the latest Zoom VDI client 3.3.2 installed in your VDI image for optimizations to work properly.  If you have a newer version of the plug-in installed in your endpoint than the client version in your VDI you will have poor or no audio/video support.

https://support.zoom.us/hc/en-us/articles/360052984292-VDI-Release-Version-3-3-2

 

0 Kudos
Enthusiast
Enthusiast

Just for clarification..

As @VMVSF pointed out earlier in this thread, the Zoom VMware Media Plugin is installed on the thin client, not on the host OS. And as @Alberte1  pointed out, Dell thin clients with 9.11, now have version 3.3.2 of this plugin pre-installed.

0 Kudos
Contributor
Contributor

You need the plugin on the client as well as the OS with the 9.1 firmware. 

Firmware has it's own issues but appears zoom works as expected. 

0 Kudos
Enthusiast
Enthusiast

Are you sure about that?  Is that  a Dell recommendation? Zoom's page and drawings show the plug in on the thin client only.

Installation

Installation of the Zoom application in a VDI environment requires two installation steps:

  • The software must be installed within the Virtual Desktop, typically within the image on the VDI server. 
  • The Zoom Media Plugin is installed on each of the thin clients accessing the VDI.

https://support.zoom.us/hc/en-us/articles/360031096531-Getting-started-with-VDI

0 Kudos
Contributor
Contributor

I worded that poorly - I see the confusion. 

I meant the OS of the virtual machine. 

I can confirm that we just rolled out 9.1 to a few users Monday - Zoom looked the same. 

Upgraded the Zoom client for VDI to 5.4 and you can now see the cpu usage go up on the thin client and fps go up in the zoom call.  

0 Kudos
Enthusiast
Enthusiast

No worries, I understood what you meant. The installation instructions I posted were from Zoom's own site, in the link provided. I'm getting confused because even their diagrams don't show the plugin installed on the desktop.

https://support.zoom.us/hc/en-us/articles/360031441671-VDI-client-features-comparison#h_70badc99-f2fd-417e-bd46-59493ab7047bhttps://support.zoom.us/hc/en-us/articles/360031441671-VDI-client-features-comparison#h_70badc99-f2fd-417e-bd46-59493ab7047b

Cool, thanks. I will give it a try both ways, if I can ever get my 8.6 clients upgraded that is. The methods Dell suggested just aren't working for me and I am stuck on 8.6_606 ATM..

0 Kudos
VMware Employee
VMware Employee

I think they are different binaries. One is "Zoom client for VDI" which needs to be installed in the remote desktop VM, the other is "Zoom media plugin" which needs to be installed in the end point machine(e.g. thin client). Both are needed for an optimized Zoom experience.

0 Kudos
Enthusiast
Enthusiast

I finally got 9.11 working (somewhat). It doesn't recognize our smart cards (but 8.6 did!) and our Yubikey devices only work 50% of the time. It seems like the Yubikeys like ThinOS and the Smart Cards work in VDI. Nothing like 3-factor authentication for security!

I found that Zoom works the same, if not worse than it did before. One thing I did find is if you boot the the client with the webcam connected and start a zoom session, the performance is very laggy, and the camera is not even listed in the Peripherals section of ThinOS.

However, if you start a VDI session with the webcam unplugged, and plug in your webcam after you have logged into Windows, and fire up Zoom, the video is MUCH better. There is no lag, but the resolution kinda sucks. And I can see the webcam in Peripherals.

Can someone else please try this and see if they get the same results?

0 Kudos