VMware Horizon Community
niccorsi
Contributor
Contributor
Jump to solution

Wrong VDI time when vm reside on some hosts

Hello Everybody,

some vdi get wrong time when booted on 2 Esxi hosts. The one on other hosts runs fine.

Client should sync time from AD. No synchronize time with host flag is applied.

All Esxi hosts are configured the same and ntpq -p shows correct time sync.

Any ideas?

I'm becoming crazy!!!

 

Thanks

 

NC

Reply
0 Kudos
1 Solution

Accepted Solutions
niccorsi
Contributor
Contributor
Jump to solution

Finally find a stable config by simply setting "Windows time" service startup to automatic. Was manual.

Osot setting was not edited so it was default.

Thanks all for help and suggestions.

Bye

Nicola

View solution in original post

Reply
0 Kudos
4 Replies
it592
Contributor
Contributor
Jump to solution

Check whether the windows client is activated

Reply
0 Kudos
niccorsi
Contributor
Contributor
Jump to solution

Thanks for your reply...

What do you mean exactly for Windows client: Windows time service or the OS itself? By the way vm are activated by an internal KMS server and Windows time service is enabled.

VDI time is strictly impacted by the client timezone (this is known and i can manage it by Horizon ADMX template).

If i open "adjust time/date" in a vdi with wrong time (=not synchronized with AD) entering admin password the vdi synchronizes immediately with domain time source.

Desktop pool setup forces a refresh at every user logout (as per Appvolumes best practices). It seems that after refresh some vms are not able to sync time...

Because the issue is not generalized but randomic on some vm.

 

Thanks

 

N

Reply
0 Kudos
Hmunning
Enthusiast
Enthusiast
Jump to solution

Are you using the Vmware Os Optimization tool? You indicate that the Windows Time Service is enabled, but is it running? I ran into this problem and it turned out to be the following setting that the OSOT sets. Do not disable this:

"Disable UBPM Autologger"

In my opinion, this setting should never be disabled. It`s killing trigger-starting of services. Services and Scheduled Tasks rely heavily on it.

I Reported a bug for this: https://flings.vmware.com/vmware-os-optimization-tool/bugs/1237 

Reply
0 Kudos
niccorsi
Contributor
Contributor
Jump to solution

Finally find a stable config by simply setting "Windows time" service startup to automatic. Was manual.

Osot setting was not edited so it was default.

Thanks all for help and suggestions.

Bye

Nicola

Reply
0 Kudos