ThinAppNeophyte
Contributor
Contributor

Why is this user session getting a timeout and disconnected?

Jump to solution

Hello,

I have some users that are getting disconnected from their view session with a message saying their session has timed out.  This is odd, because the user will be logged into their desktop working and all of the sudden they are back to the wyse terminal login screen.  If they attempt to log back in, they are taken directly back to their desktop.

I have found the messages in the debug log on the view connection server.  Why is the session disconnecting after the user has been logged in for 599 mins?

2014-01-13T17:06:13.148-06:00 DEBUG (0BFC-0CCC) <Timer-0> [al] (5AED_***_B627) Session timed out: stopping

2014-01-13T17:06:13.160-06:00 DEBUG (0BFC-0CCC) <Timer-0> [EventLogger] (5AED_***_B627) Warning_Event:[BROKER_MACHINE_SESSION_TIMEDOUT] "Session for user null timed out": Source=com.vmware.vdi.ice.server.al, UserDN=cn=s-1-5-21-903304000-123605126-2484215475-1892,cn=foreignsecurityprincipals,dc=vdi,dc=vmware,dc=int, Time=Mon Jan 13 17:06:13 CST 2014, Severity=WARNING, Node=[redacted], Module=Broker, Acknowledged=true

2014-01-13T17:06:13.160-06:00 DEBUG (0BFC-0CCC) <Timer-0> [EventWorker] (5AED_***_B627) Initialising EventWorker

2014-01-13T17:06:13.161-06:00 DEBUG (0BFC-0CCC) <Timer-0> [al] (5AED_***_B627) Notify fatal timeout error to client: Secure connection timed out (The session has timed out, please re-authenticate.)

2014-01-13T17:06:13.161-06:00 DEBUG (0BFC-0CCC) <Timer-0> [al] (5AED_***_B627) Client does not support client-timeout-error or client-error. User will not see this timeout message.

2014-01-13T17:06:13.162-06:00 DEBUG (0BFC-0CCC) <Timer-0> [al] (5AED_***_B627) Lite session stop requested: Session timed out

2014-01-13T17:06:13.162-06:00 INFO  (0BFC-0CCC) <Timer-0> [ay] (5AED_***_B627) User [redacted] Secure Gateway Server session ended - session ID: 5AED_***_B627

2014-01-13T17:06:13.163-06:00 DEBUG (0BFC-0D00) <Outbound JMS Forwarder Thread> [bj] Item on queue "Outbound JMS Forwarder" for 816 us, queue length = 0, available workers = 0 of 1

2014-01-13T17:06:13.163-06:00 DEBUG (0BFC-0D00) <Outbound JMS Forwarder Thread> [l] Sending JMS message: Logout

2014-01-13T17:06:13.164-06:00 DEBUG (0608-1FA8) <MessageFrameWorkDispatch> [MessageFrameWork] System::IsWorkerInstalled

2014-01-13T17:06:13.164-06:00 DEBUG (0608-1FA8) <MessageFrameWorkDispatch> [MessageFrameWork] System::WriteWindowsEvent

2014-01-13T17:06:13.165-06:00 DEBUG (0BFC-1E64) <EventWorker(Client)> [JMSCluster] Could not find: pae_jms.properties, using defaults.

2014-01-13T17:06:13.165-06:00 DEBUG (0BFC-1E64) <EventWorker(Client)> [JMSCluster] JMS env: {}

2014-01-13T17:06:13.166-06:00 DEBUG (0958-0DA8) <SwiftMQ-SessionPool-3> [ManagementFilter] Received Logout message from tunnel server:  Type:(MapMessage\Logout);  Headers:[Server, TunnelGeneration, TunnelVersion, Type, _MS_MSGIDENTIFIER, _MS_SIGNATURE, capID, toBroker];  Body:{}

2014-01-13T17:06:13.167-06:00 DEBUG (0958-0DA8) <SwiftMQ-SessionPool-3> [UserSessionTracker] Successfully unbound UserSessionTracker (userId=[redacted], sessionId=9399_***_3e49)

2014-01-13T17:06:13.167-06:00 INFO  (0958-0DA8) <SwiftMQ-SessionPool-3> [Audit] BROKER_LOGOFF:USER:[redacted];USERSID:[redacted];USERDN:[redacted],[redacted];

2014-01-13T17:06:13.167-06:00 DEBUG (0958-0DA8) <SwiftMQ-SessionPool-3> [EventLogger] Info_Event:[BROKER_USERLOGGEDOUT] "User [redacted] has logged out": Source=net.propero.modules.properOps.UserSessionTracker, Time=Mon Jan 13 17:06:13 CST 2014, Severity=AUDIT_SUCCESS, Node=[redacted], TotalUsers=6, UserSID=[redacted], BrokerSessionId=9399_***_3e49, Module=Broker, UserDisplayName=[redacted], Acknowledged=true

2014-01-13T17:06:13.168-06:00 INFO  (0958-0DA8) <SwiftMQ-SessionPool-3> [UserSessionTracker] User USER:[redacted];USERSID:[redacted];USERDN:[redacted]; has logged out of VDM

2014-01-13T17:06:13.168-06:00 DEBUG (0958-0DA8) <SwiftMQ-SessionPool-3> [ManagementFilter] Invalidating session (time out = 1sec): 93993c2b_d4ed_461e_8060_afe98bef3e49

2014-01-13T17:06:13.168-06:00 DEBUG (0BFC-1E64) <EventWorker(Client)> [JMSRouter] Direct JMS connect: [ name=router1, username=null, password=null, siteName=null, swiftMQHost = localhost, swiftMQPort = 4001, swiftMQSocketFactory = com.swiftmq.net.PlainSocketFactory, swiftMQKeepAlive = 60000, usingJNDINames = true ]

2014-01-13T17:06:13.168-06:00 DEBUG (0BFC-0D00) <Outbound JMS Forwarder Thread> [l] Sent MapMessage in 4 ms

2014-01-13T17:06:13.175-06:00 DEBUG (0BFC-1E64) <EventWorker(Client)> [JMSRouter] Direct JMS connect: [ name=router1, username=null, password=null, siteName=null, swiftMQHost = localhost, swiftMQPort = 4001, swiftMQSocketFactory = com.swiftmq.net.PlainSocketFactory, swiftMQKeepAlive = 60000, usingJNDINames = true ]

2014-01-13T17:06:13.964-06:00 DEBUG (0958-0EC8) <Thread-50> [TrackerObject] Sync complete: DomainHealth:[redacted] to version: 3071

2014-01-13T17:06:13.965-06:00 DEBUG (0958-0EC8) <Thread-50> [TrackerManager] Sending message: (TrackerMessage SYNC {}: {v=3071, tn=DomainHealth, u=[{"type":"SET","item":{"name":"ATTR_DOMAIN_NAME","type":"STRING","stringValue":"[redacted]"}},{"type":"SET","item":{"name":"ATTR_DOMAIN_DNS","type":"STRING","stringValue":"[redacted]"}},{"type":"SET","item":{"name":"ATTR_DOMAIN_STATE","type":"STRING","stringValue":"OK"}},{"type":"SET","item":{"name":"ATTR_DOMAIN_TRUSTTYPE","type":"STRING","stringValue":"PRIMARYDOMAIN"}},{"type":"SET","item":{"name":"ATTR_DOMAIN_CONTACTABLE","type":"STRING","stringValue":"FULLYACCESSIBLE"}},{"type":"SET","item":{"name":"ATTR_DOMAIN_ISNT4","type":"STRING","stringValue":"false"}},{"type":"SET","item":{"name":"HEALTH_LAST_UPDATE_TIME","type":"LONG","longValue":1389654373964}}], nn=[redacted], oi=[redacted]})

2014-01-13T17:06:15.925-06:00 INFO  (0958-0DD8) <DesktopControlJMS> [Audit] DISCONNECTED:Server:cn=[redacted];DNS:[redacted];IP:[redacted];USER:[redacted];USERDN:[redacted];BROKERUSERSID:[redacted];

2014-01-13T17:06:15.925-06:00 INFO  (0958-0DD8) <DesktopControlJMS> [DesktopTracker] User [redacted] disconnected from machine [redacted] for desktop vdi - session allocated at January 13, 2014 7:06:24 AM CST, connected for 599 mins 47 secs

2014-01-13T17:06:15.926-06:00 DEBUG (0958-0DD8) <DesktopControlJMS> [DesktopTracker] Agent session counts for [redacted] : sessionCount=1, pendingSessionCount=0, connectedSessionCount=0, disconnectedSessionCount=1

2014-01-13T17:06:15.927-06:00 DEBUG (0958-1EAC) <28771f0c-26cb-42c7-a27f-b6a15e40c9c6> [DesktopTracker] onEvent: DISCONNECTED - UserName:[redacted];DomainName:[redacted];UserDn:[redacted];UserSid:[redacted];GroupSids:null;BrokerUserSid:[redacted];ConnectionId:5AED_***_B627;Protocol:PCOIP;ClientName:;ClientAddress:;ServerDn:[redacted];ServerPoolDn:[redacted];ServerDnsName:[redacted];DynamicIpAddress:[redacted];ManagedObjectId:null;Id:[redacted];State:Disconnected;SessionGuid:d573-***-9d9b;PreviousSessionGuid:null;LoggedInAsDomain:[redacted];LoggedInAsUser:[redacted]

1 Solution

Accepted Solutions
nzorn
Expert
Expert

What is your session timeout set to under View Configuration > Global Settings

View solution in original post

0 Kudos
2 Replies
nzorn
Expert
Expert

What is your session timeout set to under View Configuration > Global Settings

0 Kudos
Linjo
Leadership
Leadership

The default is 600min so this is what is happening.

This counter is for the whole session, no matter if the user disconnects and connects again.

You could set this to 9999 or something to avoid that happening.

// Linjo

Best regards, Linjo Please follow me on twitter: @viewgeek If you find this information useful, please award points for "correct" or "helpful".