lenartm
Contributor
Contributor

Vmware View VDI migrating datastore link problem

I have Vsphere 4.1, View 4.5. I had two datastores for OS disks (linked clone). I have created two new bigger datastores to migrate desktops from old to new. I moved four desktops manually (migrate datastore) not rebalance. Now in summary tab i still see old datastore and new datastore. When i check settings there is no link to old datastore. The thing i noticed when i migrated desktops was that there has no replica been created. Now i have problem when i do recompose, refresh or rebalance with these four dekstops (all other desktops where done by rebalance and everything is ok).

Any idea hove to solve it?

Lenart Milanovic

0 Kudos
4 Replies
kgsivan
VMware Employee
VMware Employee

The way that you moved the linked clone is not right. Manually changing the datastore of linked clones via vSphere client will impact all the maintennace operation. View need to update the disk location in its initial check point. So to perform this, edit the pool, un-check old datastores, and select the new datastore(s) and complete the edit wizard.

Now perform a pool level rebalance. This way you can solve your problem

lenartm
Contributor
Contributor

I solved problem with datastores. The whole problem started when i changed disk on same controller - recompose or refresh is not working when you have separated disks. why i did tha - because i changed controler from bus to PV and machine didnt boot. When i changedthe rest of the disks to PV it was ok, but everything was on same controler. Now when i solved all this i still have problem with two machines (out of 100). They hang on recompose on step where desktp should restart and start customization (change name in next reboot). I get error View Composer agent initialization state error (13): More than on persistent disk has the same usage (waited 0 seconds)

Any idea on this?

Lenart

0 Kudos
kgsivan
VMware Employee
VMware Employee

As I told earlier, since you had manually edited the datastore location there are chances (no there must) impacting the pool configuration.

I would suggest any change in the datastore  should not perform manually through vCenter instead perform it using rebalnce only.

0 Kudos
lenartm
Contributor
Contributor

Solution of my problem was deleting those two machines. Problem was with internal disk (something went wrong with rebalance) so recomposing was not able to finis - no customization possible. Thanks for tip.

Lenart

0 Kudos