Highlighted
Enthusiast
Enthusiast

Vmware UAG 3.1 Reverse Proxy for a internal Web site

Jump to solution

Hello,

I must configure a internal web site on Vmware UAG 3.1, my UAG is configured for VMware Workspace and my Horizon. Now I must add one Web Site.

Example:

My web site is http://INTRANET.domain.local/intranet

My UAG is https://workspace.domain.com

I configure a new reverse proxy on configuration of my Vmware UAG but on logs /opt/vmware/gateway/esmanager.logs I have one Warning WARN networkcore.HttpsRequestRouter[channelRead: 136][]:Error message:null. No proxying rules for http request GET /intranet When I connect on https://workspace.domain.com/intranet

If you help me, thanks.

Seb

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Enthusiast
Enthusiast

Congratulations!!!

Since my browser Web when I type  https://workspace.domain.com/toto%20No%20test/welcome.aspx  In reality, the %20 is an "space", the %20 in UAG is translated to "toto No test" And my pattern I had put "(/toto%20No%20test(.*)) and not (/toto No test(.*))

With this pattern (/toto No test(.*)) my URL reverse proxy:  https://workspace.domain.com/toto%20No%20test/welcome.aspx is OK.

Thanks you for help.

View solution in original post

0 Kudos
5 Replies
Highlighted
VMware Employee
VMware Employee

How does your pattern look like for the internal application?

0 Kudos
Highlighted
Enthusiast
Enthusiast

Hi,

I found to run the reverse proxy UAG for HTTPS or HTTP internal.  But, I have one last problem for an application that is on a port 8080.

On my UAG, my proxy destination is http://siteweb.domain.local:8080 with pattern /toto%20No%20test/welcome.aspx

I configured my reverse proxy but when I type https://workspace.domain.com/toto%20No%20test/welcome.aspx , it does not work.

Have you an idea??

Should I open 8080 ports on my UAG??

Thanks

0 Kudos
Highlighted
Enthusiast
Enthusiast

Hi

You should be able to reach your internal Application from the UAG appliance. port on which the application is listening.

Let us know the result.

Regards Sumanth VCP7-DTM7 , DCV , NV, VCAP7-DTM Design If you found my answers useful please consider marking them as Correct OR Helpful
0 Kudos
Highlighted
Enthusiast
Enthusiast

Yes,

Since the appliance UAG, wget http://siteweb.domain.local:8080/toto%20No%20test/welcome.aspx is OK.

But if I test https://workspace.domain.com/toto%20No%20test/welcome.aspx is KO

And on logs esmanager.log, I have WARN networkcore.HttpsRequestRouter[channelRead: 136][]:Error message:null. No proxying rules for http request GET /toto%20No%20test/welcome.aspx

That night, I continue my test on UAG.

0 Kudos
Highlighted
Enthusiast
Enthusiast

Congratulations!!!

Since my browser Web when I type  https://workspace.domain.com/toto%20No%20test/welcome.aspx  In reality, the %20 is an "space", the %20 in UAG is translated to "toto No test" And my pattern I had put "(/toto%20No%20test(.*)) and not (/toto No test(.*))

With this pattern (/toto No test(.*)) my URL reverse proxy:  https://workspace.domain.com/toto%20No%20test/welcome.aspx is OK.

Thanks you for help.

View solution in original post

0 Kudos