morrisosu
Contributor
Contributor

View no longer provisioning new VMs....

Out of the blue our VMware View testing came to a halt yesterday when View stopped provisioning new VMs. I have to admit View's stability is really starting to be questioned as we continue to encounter bizarre issues such as these.

Just randomly we started getting these events in the View log and new VMs for this pool are no longer being provisioned:

Pool cn=8ead11ee-db57-4812-b5c9-03446574c034,ou=virtualcenter,ou=properties,dc=vdi,dc=vmware,dc=int::Unable to create new VM - VMware.Sim.Fault.InvalidParentVmFault, InvalidSnapshotDiskConfiguration

Has anyone seen this error before? Nothing changed on our parent VM, as far as I can tell anyway.

Thanks for everyone's help.

0 Kudos
3 Replies
morrisosu
Contributor
Contributor

Ok update: I migrated the (powered off) base VM to another host in the cluster and the problem vanished! Once I did this, View started catching up and provisioning again.... Who knows?

0 Kudos
SimonLong
VMware Employee
VMware Employee

Who knows indeed! vMotioning the Master VM worked for me to.






Regards Simon

-


Visit My Blog, The SLOG at: http://www.simonlong.co.uk

VCP410 Study Guides and Exams: http://www.simonlong.co.uk/blog/vcp-vsphere-upgrade-study-notes/

Follow me on Twitter: http://www.twitter.com/simonlong_

If you find this information useful, please award points for "correct" or "helpful".

Visit My Blog, The SLOG at: http://www.simonlong.co.uk
0 Kudos
JohndeRuiter
Contributor
Contributor

I was running into the same problem. View 4.6. It seems that a provisioning task was running.

An employee did a storage vmotion on the running master vm.

Provisioning ended in thousands of errors in the event db.

We kindly requested not fooling around with the master vm while running in a production environment.:smileyshocked:

After a vmotion of the powered off master vm provisioing went ok.

Is this still an issue in View 5.0.x?

0 Kudos