VMware Horizon Community
shawnwatb
Enthusiast
Enthusiast
Jump to solution

View PowerCLI Add-AutomaticLinkedClonePool

I am trying to create pools and have hit road block and need to figure out if it is in my brain or the product.  I am trying to make pools with non-persistant linked clone pool of desktops.  I ma not sure how to do the -datastoreSpecs section to break up my replica and linked clone.  in the help it says:

Note that specifying datastores with usage of 'OS', or 'Data' only is only permitted for Persistent (dedicated) pools where useUserDataDisk is set to true.

Does that mean i can't split them up unless i do Persistent clones?

Attempting to automate the world
Reply
0 Kudos
1 Solution

Accepted Solutions
4 Replies
uday_s
Enthusiast
Enthusiast
Jump to solution

Looks like the help is misleading. For a non-persistent Pool, you should be able to split Replica and OS disk (Linked clone). To check, create a small pool with 1-2 desktops to see if it's working. You can specify OS and Replica for the 'usage' value.

Reply
0 Kudos
shawnwatb
Enthusiast
Enthusiast
Jump to solution

Ok i will try that.  Is the use or Replica documented somewhere that you know of?  That was part of my frustration was trying to find full documentation.

Attempting to automate the world
Reply
0 Kudos
uday_s
Enthusiast
Enthusiast
Jump to solution

Reply
0 Kudos
shawnwatb
Enthusiast
Enthusiast
Jump to solution

from my TAM:  I received from our View SME is that this is a known bug that was fixed in version 5 of View.

Attempting to automate the world
Reply
0 Kudos