VMware Horizon Community
mdpv3
Contributor
Contributor

View Desktops Failed to Connect when Multiple Networks Are Present

We have a view environment that has 7 networks present on the desktop.  However, when we try to connect to them, it takes 4-8 attempts to connect.  We are thinking it is because the view 5 agent doesn't know what network to go out of.   In 4.6 we added the registry value to include the network that the view view server is on :

---

HKEY_LOCAL_MACHINE\Software\VMware, Inc\VMware VDM\Node Manager\subnet registry key to  n.n.n.n/m (REG_SZ), where n.n.n.n is the TCP/IP subnet and m is the number of bits in the subnet mask.

---

We also tried this in version 5.  However, we are still seeing issues.  If we remove all of the network connections and only leave the connection of the view connection server, it works without issues.  Is there a different way to make the agent talk out one network vs. many?

The error we see in view is

Unable to launch from Pool "PoolName" for user domain\username: All responding machines are currently in use.  However, the desktops are listed as "avaliable"

Reply
0 Kudos
1 Reply
WilliamReid
Enthusiast
Enthusiast

Hi there,

The status of available indicates that the agent is not having any issues with communication to the connection server.

If there was an issue with the the VDI desktop not being able to reach the broker, or vice versa you would see a status of agent unreachable for a status.

That error message indicates that something else is happening. A closer look over over the broker & agent logs might reveal whats actually happening...

Wm

Reply
0 Kudos