ms-2008
Contributor
Contributor

View Composer installation

I've installed Virtual Center, Viewer Composer, setup database and DSN on the Virtual Center server. I then login to the View Administrator, configuration, add the Virtual Center to the View Administrator and Check for View Composer Compatibility and got an error message View Compsoer is not available for this VC. What else do I need to do? Do I have to join the Virtual Center to the domain? Any help is appreciated.

0 Kudos
11 Replies
Troy_Clavell
Immortal
Immortal

Are you running ESX 3.5.0U3, in order to use composer your ESX builds must be at this level.

http://www.vmware.com/pdf/viewmanager3_admin_guide.pdf

0 Kudos
ms-2008
Contributor
Contributor

I recently downloaded the ESX 3.5.0 U3 and run an update on my ESX Server. Here is the version that I'm using. VMware ESX Server Version 3.5.0 Build 123630. I did followed the admin guide but there are some parts that confused me.

0 Kudos
lamw
Community Manager
Community Manager

Did you check to make sure the View Composer service started on the Virtual Center? Perhaps try to manually stop / start and see if you have any success with that. Also I assume your VC is u3 as well?

0 Kudos
Troy_Clavell
Immortal
Immortal

...and finally, if all the steps were taken and you still have problems,I would suggest to do an uninstall of composer and start over again, especially if you did your ESX upgrade post composer install.

0 Kudos
ms-2008
Contributor
Contributor

I did make sure the View Composer service did started on the Virtual Center. I think you might have answered my question with the VC. I'm still running VC 2.5. I'm going to download VC and try again. I'll update my status. Thanks all for your help.

0 Kudos
TomHowarth
Leadership
Leadership

Update your VC to U3 as well. also make sure the the Network Service account is being used to start the Composer service.

If you found this or any other answer useful please consider the use of the Helpful or correct buttons to award points

Tom Howarth

VMware Communities User Moderator

Blog: www.planetvm.net

Tom Howarth VCP / VCAP / vExpert
VMware Communities User Moderator
Blog: http://www.planetvm.net
Contributing author on VMware vSphere and Virtual Infrastructure Security: Securing ESX and the Virtual Environment
Contributing author on VCP VMware Certified Professional on VSphere 4 Study Guide: Exam VCP-410
0 Kudos
ms-2008
Contributor
Contributor

Thanks everyone for all the help. The View Composer is working now but I ran into another issues. When I created a new Automated Desktop Non-Perisistent Pool with use Linked Clone and Quick Prep, it failed to create the pool and got the following error message "Domain administrator account used for QuickPrep does not have sufficient permissions". I did select the domain account that belongs to domain admins group during the QuickPrep. Looking at the VC during the process, I saw that it created a tempxxx, replicaxxx and sourcexxx and register the virtual machine but then it destroyed everything after that. Our network infrastructure uses ABC.XYZ.LOCAL and not XYZ.COM. I'm not sure if that makes any different. Any thoughts?

0 Kudos
TomHowarth
Leadership
Leadership

is there a trust between the two domains

If you found this or any other answer useful please consider the use of the Helpful or correct buttons to award points

Tom Howarth

VMware Communities User Moderator

Blog: www.planetvm.net

Tom Howarth VCP / VCAP / vExpert
VMware Communities User Moderator
Blog: http://www.planetvm.net
Contributing author on VMware vSphere and Virtual Infrastructure Security: Securing ESX and the Virtual Environment
Contributing author on VCP VMware Certified Professional on VSphere 4 Study Guide: Exam VCP-410
0 Kudos
ms-2008
Contributor
Contributor

We only have one domain ABC.XYZ.LOCAL. Thanks.

0 Kudos
TomHowarth
Leadership
Leadership

Moved to the VMware View Manager Forum

Tom Howarth

VMware Communities User Moderator

Blog: www.planetvm.net

Tom Howarth VCP / VCAP / vExpert
VMware Communities User Moderator
Blog: http://www.planetvm.net
Contributing author on VMware vSphere and Virtual Infrastructure Security: Securing ESX and the Virtual Environment
Contributing author on VCP VMware Certified Professional on VSphere 4 Study Guide: Exam VCP-410
0 Kudos
be2k
Enthusiast
Enthusiast

Hello,

i am in trouble. The View Composer service wont come up ... on the first installation of the View Composer i set the service with "login as" to our lokal admin of the VC but this dont help this time

someone have an idea to fix this ?

0 Kudos