VMware Horizon Community
GuillaumeARRQ
Contributor
Contributor

View Composer and QuickPrerp

I have finally succeeded in creating an automated desktop pool with support of linked clone ...

Everything runs fine EXCEPT QuickPrep. For an unknown reason, every desktop is stuck with the parent VM name. The IP address of the clone change and the computer account is created in the AD. But, the computer name of the parent VM stays in the clone.

Any idea ?

Reply
0 Kudos
4 Replies
lbourque
Virtuoso
Virtuoso

What is the parent name you've chosen for the VMs? Remember that there is a 15 character limit (INCLUDING the numbers) for the VMs.

GuillaumeARRQ
Contributor
Contributor

The VMs names are T00VVGAUTO*.

I'll check the firewall setting though. My guess is that the view server can't talk to the VM...

I'll update with my findings ...

Reply
0 Kudos
GuillaumeARRQ
Contributor
Contributor

Well, after some more fiddling ans searching, I found out that QuickPrep doesn't generate a new SID for each clone. This is bad. It actually doesn't explain why the QuickPrep doesn't work, but since there's no new SID, I'll have to reconsider using the product. So I'll not pursue my search...

Reply
0 Kudos
lbourque
Virtuoso
Virtuoso

This is the nature of Linked Clones and is documented in the Admin Guide. You could, however, run a script once (post syncronization script with Newsid) the VM is ready to generate a new sid. Only a few applications actually have a need for a specific SID (in the domain it will have a new RID in the Domain).

If you go the script route keep in mind you'll need to limit the refresh/rebalance/recomposition options as those will reset the OS back to the original SID.

Reply
0 Kudos