VMware Horizon Community
RickJSalt
Enthusiast
Enthusiast

View Composer Fault - Host has been disconnected

I am currently running View Administrator 6.1.0 build-2509221

One of my pools is showing the following error:

Error during provisioning: View Composer Fault: Unexpected VC fault from View Composer (HostNotConnected) - Host has been disconnected in VirtualCenter - <fault xsi:type="HostNotConnected" xmlns="urn:internalvim25" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" />

In checking around one suggestion is that I had a corrupted snapshot.  I had to apply some updates to the parent anyway, so once I did that I created a new snapshot and scheduled a recompose of the pool based on the new snapshot, in the middle of the night.  This morning several machines were still 'customizing' but in time, several started up and users are able to access machines in the pool.  However, the error still persists.

Any ideas on how I can resolve this?

Tags (2)
2 Replies
TechMassey
Hot Shot
Hot Shot

The first item to focus on is if the host in fact disconnected. Correlate the error in the events for the pool with the events on the named host. Likely, the host did disconnect and vCenter tracked it. This isn't an uncommon scenario in Horizon View depending on number of concurrent operations.

If the host is healthy and if in Horizon View Administrator, the host shows green in the health view. Then disable provisioning on the affected pool and then enable provisioning. The error should then be cleared.


Please help out! If you find this post helpful and/or the correct answer. Mark it! It helps recgonize contributions to the VMTN community and well me too 🙂
RickJSalt
Enthusiast
Enthusiast

Thank you TechMassey!  That did it.  I right clicked on the pool and Enabled Provisioning.  The error went away immediately and the pool is acting as it should.