jmbrack
Contributor
Contributor

View Agent with Windows7

Has anyone ran into a compatibility error when loading the VMware View Agent on a 64-bit Windows 7 virtual machine?  I receive the following error:

The version of this file is not compatible with the version of Windows you're running.  Check your computer's system information to see whether you need an x86 (32-bit) or x64 (64-bit) version of the program, and then contact the software publisher.

Seems like an easy error.  I'm loading VMware View Agent 64-bit build 5.1.1-799444

Joe

0 Kudos
7 Replies
Linjo
Leadership
Leadership

Have not seen this, did you verify the MD5 hash?

What is the complete filename that you downloaded?

// Linjo

Best regards, Linjo Please follow me on twitter: @viewgeek If you find this information useful, please award points for "correct" or "helpful".
0 Kudos
jmbrack
Contributor
Contributor

I did verify the MD5 hash.  The file I downloaded is VMware-viewagent-x86_64-5.1.1-799444.exe.

I'm trying to install it on a 64-bit Windows 7 SP1 virtual machine.  I did also try to load it on a heavy Windows 7 machine as well with the same error.

Any ideas?

0 Kudos
Dave_McD
Contributor
Contributor

Just playing devils advocate, what happens if you try and installed the standard view agent, not the 64 bit one?

0 Kudos
jmbrack
Contributor
Contributor

The installer for the 32-bit version actually starts up and then errors out (before hitting next - next - etc) saying that this version will not work with this verison of Windows.  Load the 64-bit version.  For the 64-bit version, the installer never begins, I just get the error right off the bat.

0 Kudos
Dave_McD
Contributor
Contributor

It sounds like a problem with the build. Is it just happening on 1 desktop, or is it happening to all desktops?

Also, when you initially created the VM did you choose 32 bit or 64 bit windows?This might happen in you create a 32-bit VM then load Windows 7 64-bit on it?

check your VM settings under Options and see what OS version it is using.

0 Kudos
jmbrack
Contributor
Contributor

I tried it on one VM and on two desktops.  I may rebuild the VM tomorrow and try again.

0 Kudos
jmbrack
Contributor
Contributor

I ended up reloading a VM with Windows 7 32-bit (works for the software I'm trying to load) and loaded the 32-bit agent.  That seems to work without any issues.  I'll revisit the 64-bit issue in the future.

0 Kudos