jayache80
Contributor
Contributor

View Agent Direct Connection not working for me

Jump to solution

I cannot get Direct Connection to work. I have VMs with View Agent and Direct Connection plugin installed that work fine when accessed through the Horizon View Connect Server where the VMs are in pools. However, when I try to connect directly to those VMs (using either a zero client or VMware Horizon Client) it fails. (VMware Horizon Client just times out, and an HP t310 zero client just immediately fails "View Connection Server communication error").

I noticed that port 443 is not open on these VMs that I wish to Direct Connect to. Is this why? Does anyone have any suggestions?

0 Kudos
1 Solution

Accepted Solutions
jayache80
Contributor
Contributor

Got it working. It was because I had the older View Agent 7.0.1 installed, and tried installing Direct Connection 7.0.3 onto that. I upgraded everything 7.0.3 and Direct Connect works.

View solution in original post

0 Kudos
7 Replies
mougT
Enthusiast
Enthusiast

Hi

Yes port 443 must be open on these vm's. The client connects to a web service running on port 443 the same way they would connect to a connection server.

0 Kudos
jayache80
Contributor
Contributor

Do you happen to know any reasons why port 443 might not open? I have no firewalls on this machine and the network is wide open. The agent is running , and I figured that it would make a socket and listen on 443 as part of its job.

0 Kudos
mougT
Enthusiast
Enthusiast

If the direct connection plugin was correctly installed, your system should listen on port 443. You can check with "netstat -a".

Do you have any other software on your vm using the same port? You can change the listening port for the view agent:

https://pubs.vmware.com/horizon-61-view/index.jsp?topic=%2Fcom.vmware.view-agent.directconnectionplu...

Remember that if you change the listening port, you must also specify the port on your client. (f.eks myvm.mycomp.com:444)

0 Kudos
jayache80
Contributor
Contributor

Thanks for helping me out. When installing, I chose 443, but netstat -anob shows nothing running on port 443. Then I uninstalled it, and re-installed it to choose 444- nothing running on 444. Thinking it may be protected ports that low in value, I tried to install it using 64443, no dice. I guess the installer isn't installing it properly. I can't find any settings for it in Group Policy Editor, which there should be, also making me think it's not getting installed...

Any ideas?

0 Kudos
jayache80
Contributor
Contributor

Also looking at the registry: HKLM\Software\VMware, Inc.\VMware\VDM\Agent\Configuration\XMLAPI

shows normally NOTHING. However, this time it shows one key: httpsPortNumber set to 64443... I really don't think it's getting installed properly- trying a previous installer now...

0 Kudos
jayache80
Contributor
Contributor

Got it working. It was because I had the older View Agent 7.0.1 installed, and tried installing Direct Connection 7.0.3 onto that. I upgraded everything 7.0.3 and Direct Connect works.

0 Kudos
mougT
Enthusiast
Enthusiast

Good thing you got it working Smiley Happy

0 Kudos