VMware Horizon Community
gmtx
Hot Shot
Hot Shot
Jump to solution

View 6.0.2 agent and disposable disk error

I've got a Windows 7 64-bit master image I've been using for quite some time for linked clone deployments. I'm running View 6.0.1 and I recently updated the View agent on my master image 6.0.1 to 6.0.2 to test scanner redirection. Now when I try to recompose an existing pool or create a new linked-clone pool with the 6.0.2 agent master image, the deployment fails on all linked clones with "Error 9" (failed to relocate disposable) in the Composer logs on each VM. I can't find any relevant KB articles that match my situation, and uninstalling the 6.0.2 agent and re-installing 6.0.1 fixes the problem. Any idea how to troubleshoot this?

Thanks,

Geoff

Reply
0 Kudos
1 Solution

Accepted Solutions
gmtx
Hot Shot
Hot Shot
Jump to solution

Just got an email back from support:

"I wanted to let you know that we are aware of the problem, and that the fix is already in View 6.1.0.  Right now, we're testing this new version, and will release it sometime in the next few months.  I apologize that I can't be more specific on the date, as I don't think anyone really knows for sure.  Please fall back on to the View 6.0.1 Agent until View 6.1.0 is released. "


So back to 6.0.1 I go, and scanner redirection will have to wait.


Geoff

View solution in original post

Reply
0 Kudos
7 Replies
jharvs19
Contributor
Contributor
Jump to solution

I have the same issue with upgrading from View agent 6.0.1 to 6.0.2. If I log into one of the linked clones that’s having the issue “Error 9” I can see it has correctly attached a hard drive for disposable space. I’m wondering if this is a false error. I have noticed that if I try to log into the linked clone with a domain account I get an error and can't log into the computer. The only change I have made to the gold image is the agent version. When I look in AD I can see the newly created link clone is passing bad computer passwords.In the error message is says pairing state: Paired and secured. Wondering if you see the same thing.

Reply
0 Kudos
gmtx
Hot Shot
Hot Shot
Jump to solution

I also see the disposable disk is there (though it's missing the usual "Temp" folder) when I log into one of the broken linked clones from the console. Haven't actually tried logging into one of them with the View client, and I nuked the broken pool so I can't try it right now. I'll try another deployment with the 6.0.2 agent master mage and see if my results match yours, but with you also having the same issue I think it's something VMware will need to look at. Guess I really should open a ticket.

Geoff

Reply
0 Kudos
mittim12
Immortal
Immortal
Jump to solution

Have you seen this KB?   VMware KB: Deploying or recomposing a linked clone pool fails with the error: Failed to relocate dis...       I also think opening a ticket would be a good idea.   This way if it is a bug then they can document it or at the very least maybe they have a private fix for it.

Reply
0 Kudos
gmtx
Hot Shot
Hot Shot
Jump to solution

I did see that KB article, thanks, but nothing in there matches my configuration.

I just opened a ticket (15603301702) so we'll see what support has to say.

Geoff

Reply
0 Kudos
Gaurav_Baghla
VMware Employee
VMware Employee
Jump to solution

Hi Geoff,

Please downgrade the Agent to 6.0.1 and let me know th results

Regards Gaurav Baghla Opinions are my own and not the views of my employer. https://twitter.com/garry_14
Reply
0 Kudos
nzorn
Expert
Expert
Jump to solution

Gaurav,

I'm not Geoff, but he said this in his first post:

"uninstalling the 6.0.2 agent and re-installing 6.0.1 fixes the problem."

Reply
0 Kudos
gmtx
Hot Shot
Hot Shot
Jump to solution

Just got an email back from support:

"I wanted to let you know that we are aware of the problem, and that the fix is already in View 6.1.0.  Right now, we're testing this new version, and will release it sometime in the next few months.  I apologize that I can't be more specific on the date, as I don't think anyone really knows for sure.  Please fall back on to the View 6.0.1 Agent until View 6.1.0 is released. "


So back to 6.0.1 I go, and scanner redirection will have to wait.


Geoff

Reply
0 Kudos