VMware Horizon Community
duhaas
Enthusiast
Enthusiast

View 5.1 Composer Unable to select snapshot

Starting to play around with View 5.1 Composer and am unable to select the latest snapshot:

http://monosnap.com/image/fOp6BND3sHQlSx32R4jVWiDL6.png

Might be obvious, but just learning the ticks with composer, the snapshot is version 8 of hardware, the desktops now are hardware version 8, not sure what I'm missing?

Tags (1)
Reply
0 Kudos
5 Replies
nzorn
Expert
Expert

Did you upgrade VM Tools before the hardware version and then the Agent?

Reply
0 Kudos
nzorn
Expert
Expert

Here's the official answer:

NOTE If you are also upgrading the virtual hardware version, such as upgrading to virtual hardware version
8 or later, included with vSphere 5 or later, the snapshot of the upgraded parent virtual machine is used to
upgrade the virtual hardware version of the rest of the virtual machines in the linked-clone pool.
Upgrading in this way, from one virtual hardware version (or compatibility level) to a higher version, is
supported. You cannot, however, recompose linked clones to a lower hardware version than their current
version. For example, you cannot recompose hardware version 8 clones to a parent virtual machine that is
hardware version 7.

Reply
0 Kudos
duhaas
Enthusiast
Enthusiast

Thats a great question and am unsure, I'm taking the envrionment over from someone that isnt around anymore.  The only change I've made is upgrading VMware Agent in the VM after upgrading the view infrastructure to latest 5.1 release

Reply
0 Kudos
duhaas
Enthusiast
Enthusiast

Thoughts on the best way to prove that theory in my case?  I'm looking @ the Parent VM and its already @ HW version 8, and since all the deployed desktops are running with version 8, i'm assuming things were done in the correct order.

Reply
0 Kudos
nzorn
Expert
Expert

From your screenshot you are trying to perform a recompose.  From my second post it sounds like you need to modify the default image in your pool and then delete all of your desktops and let them rebuild.

So I guess the question is can you set the new snapshot as the default image in your pool?

Reply
0 Kudos