VMware Horizon Community
maros141
Contributor
Contributor
Jump to solution

View 4.5 over PCoIP vs Windows 7 Resolution Setting Tab

Hello,

I have installed View 4.5 and I am using Samsung NC190 PCoIP zero klient. But I have problem with Windows 7 Screen resolution setting tab.

If I connect to View desktop from vSphere client I can change display resolution . (picture Windows_Resolution_Setting_tab_over_vSphere_client.jpg)

If I connect to view desktop from Samsung NC190 or View client 4.5 over PCoIP session I can not change display resolution settings or setting "Make text and other items lager or smaller" (Windows_Resolution_Setting_tab_PCoIPsession_over_View_Client.jpg) In this case I see at the top of the screen "Some settings are managed by system administrator". But I do not have any GPO witch disable or deny changing display resolution for domain users.

Have anybody any advice ?

Thanks a lot

Maros

Reply
0 Kudos
1 Solution

Accepted Solutions
chaz112182
Enthusiast
Enthusiast
Jump to solution

Hello,

This is by design. pcoip will automatically resize the window to the native resolution of the monitor. I just went through the same process you are going through now. I don't agree with the way it works, but it is what it is. You have three options:

a) use the native resolution (this is great for me, but a lot of my users are older and like to use a lower resolution so that icons, etc are bigger)

b) grab the vdm_agent group policy administrative template and make a group policy object that changes the 'toggle display settings control' to disabled.

c) change the value of the "NoDispSettingsPage" from 1 to zero

these are all for windows xp but i assume it will work the same with 7.

let me know if you have any more questions.

View solution in original post

Reply
0 Kudos
17 Replies
chaz112182
Enthusiast
Enthusiast
Jump to solution

Hello,

This is by design. pcoip will automatically resize the window to the native resolution of the monitor. I just went through the same process you are going through now. I don't agree with the way it works, but it is what it is. You have three options:

a) use the native resolution (this is great for me, but a lot of my users are older and like to use a lower resolution so that icons, etc are bigger)

b) grab the vdm_agent group policy administrative template and make a group policy object that changes the 'toggle display settings control' to disabled.

c) change the value of the "NoDispSettingsPage" from 1 to zero

these are all for windows xp but i assume it will work the same with 7.

let me know if you have any more questions.

Reply
0 Kudos
mittim12
Immortal
Immortal
Jump to solution

In addition to what Chaz has stated I also ran into an issue with the P20 zero client I was testing. It seems that the P20 would login to the View machine and utilize the optimal resolution for the monitor. In order to change that resolution I had to update the P20 the latest firmware which allowed for resolution to be set on the zero client.






If you found this or any other post helpful please consider the use of the Helpful/Correct buttons to award points

Twitter: http://twitter.com/mittim12

Reply
0 Kudos
chaz112182
Enthusiast
Enthusiast
Jump to solution

interesting i am running p20s as well. what version of firmware does the p20 need to be at ? and is the firmware update in addition to what i have already mentioned above ?

thanks for that info.

Reply
0 Kudos
mittim12
Immortal
Immortal
Jump to solution

I made no changes to the OS, I simply updated my firmware to version 3.2. Once it was updated there was a tab under options, preferences (maybe), and then display. You could set the resolution to what you wanted.






If you found this or any other post helpful please consider the use of the Helpful/Correct buttons to award points

Twitter: http://twitter.com/mittim12

Reply
0 Kudos
chaz112182
Enthusiast
Enthusiast
Jump to solution

beautiful , thanks . unrelated question in terms of firmware for the p20s.

is there a difference between the firmware teradici provides and firmware that wyse provides or is it the same ?

thanks again that's huge as i have a lot of users requesting this functionality.

Reply
0 Kudos
mittim12
Immortal
Immortal
Jump to solution

I'm not sure if there is any difference. I got mine from the link below and it was the 3.2.1 version

http://www.wyse.com/serviceandsupport/support/dlOraFW.asp?which=114&model=P20(Wyse%20Zero%20Clients)






If you found this or any other post helpful please consider the use of the Helpful/Correct buttons to award points

Twitter: http://twitter.com/mittim12

Reply
0 Kudos
mittim12
Immortal
Immortal
Jump to solution

I'm not sure if there is any difference. I got mine from the link below and it was the 3.2.1 version

http://www.wyse.com/serviceandsupport/support/dlOraFW.asp?which=114&model=P20(Wyse%20Zero%20Clients)






If you found this or any other post helpful please consider the use of the Helpful/Correct buttons to award points

Twitter: http://twitter.com/mittim12

Reply
0 Kudos
PCoIPinsider
Enthusiast
Enthusiast
Jump to solution

There are no differences in the firmware.

Regards

Ian

Reply
0 Kudos
TravisT
Enthusiast
Enthusiast
Jump to solution

I have the P20 as well and ran into the same issue. I ended up setting a GPO preference to update the registry:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\NoDispCPL to from 1 to 0

-- Travis

maros141
Contributor
Contributor
Jump to solution

Thanks a lot for tips.

I used VMware View ADM template for View agent configuration. User now can change resolution.


Toggle Display Settings  ControlDisabled

Maros

Reply
0 Kudos
vpn42
Contributor
Contributor
Jump to solution

With the P20 I found that I can change the Resolution within View Manager. It's part of the View settings for the VM. 

Reply
0 Kudos
JasonPearceAtRi
Enthusiast
Enthusiast
Jump to solution

Updating the VMware Group Policy so that users may modify their display settings (kb.vmware.com/kb/1020809) does not do much good. All it changes is the size of the window that is displaying the user's desktop. It doesn't let them lower the virtual desktop resolution while streching the desktop to fit the size of the monitor (how physical desktops perform).

Is there a way for a PCoIP connection to lower the resolution of their virtual desktop while streching the desktop image to fill monitor?

Reply
0 Kudos
vpn42
Contributor
Contributor
Jump to solution

Are you using a thinclient? are you using a Wyse? On our R50L PCOIP devices I had to set the View 4.6 client settings within the WLX.ini file which gave me full screen like a PC and you can set the display at the device within admin mode since I have them locked down. I think it depends on what your using for an end point connection device? I also set the Video RAM on the VM to be 128 and then you can turn the PCOIP connection within View to be the highest resolution available and select 4 monitors if your running view connection brokers. I think we need more information.

Reply
0 Kudos
JasonPearceAtRi
Enthusiast
Enthusiast
Jump to solution

vpn42,

Thank you for responding. The majority of our users are using WYSE C50LE thin clients and a wide range of physical monitors.

In VMware View Administrator I configured the Max resolution of any one monitor to be 1680x1050, but the virtual desktops to not seem to honor this setting and simply display the desktop at a much higher resolution when in Full Screen mode.

In vSphere, the parent virtual machine of this desktop pool has 128 MB of "total video RAM" assigned to it.

Our younger users welcome the higher resolution and like Windows 7's ability to snap one application to the left half of the monitor and a second application to the right side of the monitor. Works well for those who are 40 our younger.

Our older users (40+), however, have a difficult time reading text at the default resolution. They desire a way to lower the virtual desktop's resolution while having the virtual desktop stretch to fill the full screen.

Currently, when they change the virtual desktop's resolution the window simply resizes (get's smaller) and does not increase the size of the applications, text, and icons.

We attempted Windows 7 > Control Panel > All Control Panel Items > Display > Make it easier to read what's on your screen, option. But we have two clinical applications that become unsuable (menu options disappear) if the display is set at 125 percent or 150 percent.

This is why I'm looking for a way to a) lower the resolution of the virtual desktop while b) have the virtual desktop strech to fill the full screen. We need to do this via PCoIP for most of our users have USB devices like scanners.

Our WYSE wlx.ini file looks like this (I obscured some IP addresses):
IniFileSource=cache
Update.Mode=Both
Keyboard=us
Timeserver=172.0.0.0.
Timeformat="24-hour format"
TimeZone="EST5EDT" ManualOverride=1
Autologin=Yes Countdown=1
DefaultUser=guest
Privilege=Low SuppressTaskbar=auto
PnliteServer=172.0.0.0.
CONNECT=VMWARE_VIEWCLIENT \
Description="Desktops" \
Host=desktops.domain.local \
Port=443 \
AutoConnect=yes \
Desktopsize=fullscreen \
Interactive=no \
UseSSL=yes \
LocalCopy=no \
I hope this extra information helps. Please let me know if you or anyone else has any further questions. Thank you for your help.
Reply
0 Kudos
vpn42
Contributor
Contributor
Jump to solution

*************************************************************

;*                          View                       *

*************************************************************

CONNECT=VMWARE_VIEWCLIENT \

Description="Whatever you want here" \

Fullscreen=yes \

UseAllMonitors=yes \

Host=your host \

UseSSL=yes \

AutoConnect=yes \

DesktopSize=useallmonitors \

Interactive=no \

Reconnect=yes \

ReconnectSeconds=3 \

LocalCopy=no

I assume the C50 Devices are like the R50L Suse Linux devices that we have. I set the resolution on the device itself. The WLX.ini settings should help getting it to use the full size of the screen.

I hope this helps for what you’re looking to accomplish. A VMware support tech said for me to set the resolution within view to be the highest and to set the available monitors to 4 to avoid any potential issues with view 4.6. You also have to power down your VM’s after changing a setting in view for it to take hold.

Reply
0 Kudos
vpn42
Contributor
Contributor
Jump to solution

*************************************************************

;* View *

*************************************************************

CONNECT=VMWARE_VIEWCLIENT \

Description="Whatever you want here" \

Fullscreen=yes \

UseAllMonitors=yes \

Host=your host \

UseSSL=yes \

AutoConnect=yes \

DesktopSize=useallmonitors \

Interactive=no \

Reconnect=yes \

ReconnectSeconds=3 \

LocalCopy=no

I assume the C50 Devices are like the R50L Suse Linux devices that we have. I set the resolution on the device itself. These WLX.ini settings should help getting it to use the full size of the screen.

I hope this helps for what you’re looking to accomplish. A VMware support tech said for me to set the resolution within view to be the highest and to set the available monitors to avoid any potential issues with view 4.6. You also have to power down your VM’s after changing a setting in view for it to take hold.

Randy…

Reply
0 Kudos
JasonPearceAtRi
Enthusiast
Enthusiast
Jump to solution

vpn42,

Thank you again for responding. I added the three values to our .ini file:

Fullscreen=yes \

UseAllMonitors=yes \

DesktopSize=useallmonitors \

This did not seem to make any difference. Even if the PCoIP session is opened Fullscreen, if the user in the Windows 7 virtual desktop attempts to resize the display to a lower resolution, the size of the desktop window simply decreases and does not stretch to fill the screen.

The desire is to lower the resolution while having the virtual desktop stretch to fill the screen.

Reply
0 Kudos