Kastigar12
Contributor
Contributor

View 4.0 and VM via PCoIP has Problem with vSphere?

We have a vSphere 4.0 Env. with View 4.0.

If we try to use an VM via PCoIP, host and vms in vSphere Client does not show names:

8962_8962.JPG

If we access vm via RDP, vsphere work just fine.

We have a resolution problem, whichwas solved with avm reseting via view manager. But this issue stil there. If any of you has a clueplease let me know.

Thanks

0 Kudos
15 Replies
Linjo
Leadership
Leadership

A workaround is to:

uninstall the vSphere client and .Net framework > uninstall the view agent > reinstall vmware tools > reboot > install agent > reboot > install .Net framework and vSphere Client.

Best regards,

Linjo

If you find this information useful, please award points for "correct" or "helpful".

Best regards, Linjo Please follow me on twitter: @viewgeek If you find this information useful, please award points for "correct" or "helpful".
0 Kudos
Kastigar12
Contributor
Contributor

Thanks for you quick reply, but I have tried this workaround already. It do not work for me.

But I will try again.

0 Kudos
acavali
Contributor
Contributor

It is very important that you remember to reboot inbetween all of those steps.

0 Kudos
Kastigar12
Contributor
Contributor

I do as follow on the parent vm:

- uninstalled vSphere client,.net framework, view agent, vmware tools

- installed vmware tools, view agent,.net framework, vSphere client

- I reboot vm after each step

- take parent vm offline and made a snap shot.

- recomposite old linked clone vm with a new snapshot

- start view client and connect to the vm via pcoip

I still do not see any names in vSphere client

Please help!

0 Kudos
Kastigar12
Contributor
Contributor

I took just a new vm, made from cleane windows xp installation. Installed vmware tools, rebooted, installed vmware agent 4.0.1, rebooted, installed vspehre with .net framework and added as individual desktop.

The problem is still there. Are you sure that is a workaround, did you test it on yourself?

0 Kudos
admin
Immortal
Immortal

What version of ESX is your desktop VM running on?

WP

0 Kudos
admin
Immortal
Immortal

Specificly 4.0 or 4.0 U1 ?

WP

0 Kudos
Kastigar12
Contributor
Contributor

I think it is U1 (4.0.0 build 208167).

0 Kudos
admin
Immortal
Immortal

There are at least three cases where we know this happens. None seem to apply to your case and what you did should have resolved it. I am going to assume the VM is not Win7.

From a VM with the issue. Go to the display properties. Go to advanced, go to troubleshoot. From the hardware acceleration section. Drop down the acceleration three settings.

Try again and see if it still happens.

WP

admin
Immortal
Immortal

Actually.... reading your message closer. I see you are running View 4.0 not 4.0.1 . I think you do fit into one of the categories. Try what I just posted.

WP

0 Kudos
Kastigar12
Contributor
Contributor

You are right, we have View Server 4.0.0.

And you have right too about VM. Discresing of hardware acceleration level to "Disable all DirecDraw and Direct3D accelerations" make vSphere client work propertly by connecting via PCoIP.

I will update View Server to 4.0.1 and test again. Or what we can do is this case?

Big thanks!

0 Kudos
Kastigar12
Contributor
Contributor

This issue will be solved also, if increase a video ram for the vm. I have set to 64 mb and could also see vsphere client propertly without changing display settings or installing all thing in the right order. I just update vspehre client on the vm, where the problem exist too, increase video memmory and could access vsphere client without problems.

I should also change video memmory of parent vm for the auto pool to have all thing working propertly.

0 Kudos
Kastigar12
Contributor
Contributor

Hello again. The things do not work as i think. If I change video ram of vm via "edit settings" and logon - it works. But if a vm belong to a pool, video ram settings will be managed over pool settings. In pool setting you can not set a video ram explicit, you can just set number of monitors and max resolution to be supported.

So, i thought, the only thing i need is to find out which combination of monitors and resolution will force amount of video ram over 64 mb.

It is 3 Monitors with 16001200 - 65,2MB (If you choose 2 monitors with 25601600 it is just 62,5)

But it did not helps with vspehre client. If I start vm changed via pool settings the problem is still exist. IF you change manual vm settings to 64 mb video ram, it works, over pool don't.

But last thing i tried is to set 3 monitors with 2560*1600 resolution, what force vm to have 128 mb ram and then vsphere client works just find.

With pcoip problems am I like Don Quixote against windmills

Why it can not just work?

0 Kudos
Linjo
Leadership
Leadership

Follow these steps and it will "just work" Smiley Wink

http://www.thatsmyview.net/2009/12/18/how-to-get-pcoip-with-view-4-to-work-every-time/

est regards,

Linjo

If you find this information useful, please award points for "correct" or "helpful".

Best regards, Linjo Please follow me on twitter: @viewgeek If you find this information useful, please award points for "correct" or "helpful".
0 Kudos
Kastigar12
Contributor
Contributor

Please, not again.

I find this solution 3 days ago. The results are all in this topic.

0 Kudos