VMware Horizon Community
Tifoso
Contributor
Contributor

VMware Horizon 8.4 (2111) - Keyboard AltGr

We have following problem.

if someone uses special characters with the key combination "AltGr" + @ or | (pipe) or similar, then the keyboard loses the focus in the VDI session (keyboard sync is active). Users can't use the cursor or enter button after this special characters have been added with "AltGr" keyboard button. Users can revert back the focus with "CTRL + WIN" or you use the key combination "Ctrl + Alt" instead of the keyboard button "AltGr".

Config VDI
- Version 2111
- Windows 10 Pro, Language US english.
- VDI Keyboard German (Swiss)
- Client Keyboard German (Swiss)
- VMware Horizion Client for Windows (2111)

Anyone has a clue how to fix this problem? Is this a bug or a feature? 😉
Many users are using keyboard button "AltGr" to add special characters.

Reply
0 Kudos
4 Replies
amc1989
Contributor
Contributor

Hello Tifoso,

I´m just running into the same problem ... Same config - beside keyboard is native German. Have you already got an solution to get rid of this new behavior which was not so before 2111 client version of Horizon View ...

Thank you very much - Heinz

Reply
0 Kudos
westbounce
Contributor
Contributor

Hi All, is there a solution to the issue yet? Regards Stefan  

Reply
0 Kudos
amc1989
Contributor
Contributor

Hi Stefan,

because I got no answer regarding this problem last year, I just remember, that I did a fresh install of Horizon Client - after I had removed old HorizonClient-Installation before from device.

Software Version higher than Horizon Client 2111-8.4.0-18968194 and version Horizon Agent 8.4.0-19446757 should work without AltGr-Problem.

Best regards 

Heinz

Reply
0 Kudos
jujo_am
Contributor
Contributor

Confirm to still plague version 2309.1 build 8.11.1 (22783278). Still looking for solution. It's hard to teach new tricks to +100 end users.

It's only the leftmost Ctrl that AltGr breaks. Clicking it returns behaviour to normal. Also if focus is lost on Horizon client and returned, it works normally again.

--

Same problem with 2312, 8.1.0 (23149293). Uninstalled client before reinstalling.

Connecting VDI with RDP after Horizon client shows normal behavior with AltGr, therefore limits problem scope only to Horizon client.

Reply
0 Kudos