VMware Horizon Community
vmmaj
Enthusiast
Enthusiast
Jump to solution

VMWare View - Physical Desktop Privacy

Hi all,

I am testing out View and connecting to physical desktops. My environment is 7.5.4, using the latest agent. Physical machine is Windows 10 version 1803.

I have it working and it seem to work well so far but the screen on the physical desktop is wide open and anyone can see what is going on. Is there a way to prevent this.

Also the dual monitor setup on the desktop has to be reconfigured if you made a view session with a single monitor device like a laptop.

Thanks.

Martin.

1 Solution

Accepted Solutions
jonathanjabez
Hot Shot
Hot Shot
Jump to solution

Thank you for briefing the issue. I understand what you are referring to. Both PCoIP and Blast protocol has the ability to control this using a group policy. You can use one of the PCoIP or Blast ADM template and disable this feature. This can be achieved  by applying this policy via domain GPO or local GPO. Please give it a try and let me know.

1.png

Reference blog:

https://www.ivobeerens.nl/2012/07/31/shadow-a-vmware-view-desktop-session/

View solution in original post

9 Replies
vmmaj
Enthusiast
Enthusiast
Jump to solution

Still looking for an answer on this.. I'd really like to use this option but really can't have an open desktop for all to see while it is being used by a View Client.

Thanks.

Reply
0 Kudos
jonathanjabez
Hot Shot
Hot Shot
Jump to solution

Your Response: physical desktop is wide open and anyone can see what is going on. Is there a way to prevent this.

What do you mean wide open? Are you referring to the VMware Horizon Client showing the desktop session always open? Could you please explain your query in detail?

Reply
0 Kudos
vmmaj
Enthusiast
Enthusiast
Jump to solution

What i'm referring to is the physical desktop screen shows everything that the user is doing remotely instead of being blacked out like a regular RDP session does. So if someone happened to pass by a physical desktop that was being remote controlled by a view client they could see the entire session. Regular RDP sessions go to black screen when being remote controlled.

Thanks.

M.

Reply
0 Kudos
jonathanjabez
Hot Shot
Hot Shot
Jump to solution

Thank you for briefing the issue. I understand what you are referring to. Both PCoIP and Blast protocol has the ability to control this using a group policy. You can use one of the PCoIP or Blast ADM template and disable this feature. This can be achieved  by applying this policy via domain GPO or local GPO. Please give it a try and let me know.

1.png

Reference blog:

https://www.ivobeerens.nl/2012/07/31/shadow-a-vmware-view-desktop-session/

vmmaj
Enthusiast
Enthusiast
Jump to solution

Awesome!!! Thank you so much for this information.

Hunter-H
Contributor
Contributor
Jump to solution

Did this end up working for you?  I'm confused as to how this setting would fix the problem.  It seems like the default behavior is already what it should be.  Isn't a view client using vmware blast different than a vsphere console seeing activity of someone connected via Pcoip?  Seems like the opposite issue.

Reply
0 Kudos
chrisdhalstead
VMware Employee
VMware Employee
Jump to solution

Make sure to follow the guidance in:  https://techzone.vmware.com/resource/using-horizon-access-physical-windows-machines

 

Chris Halstead
Senior Staff Architect, EUC Technical Marketing
chalstead@vmware.com
Twitter: @chrisdhalstead
Reply
0 Kudos
bjohn
Enthusiast
Enthusiast
Jump to solution

@vmmaj @Hunter-H 

Anyone have an answer on this? How can we blank out the screen on psychical machines?

Thanks

Reply
0 Kudos
ishki
Contributor
Contributor
Jump to solution

 I also wonder whether someone found an answer to this. We have now one new high end graphic workstation where this issue exist, while number of previously set up machines work just fine without revealing the local screen. The troubled machine has Nvidia A5000 graphic card with WHQL driver installed. We've tried two latest versions of Horizon Agent and the GPO settings suggested above. Win10 Ent 22H2 with latest monthly patches.

Reply
0 Kudos