wedge07
Contributor
Contributor

VMWare Horizon Client for macOS is downright awful (aka SSL error when attempting to log in.)

I've been using Horizon Client long enough to know that every time an update comes out it will pretty much break something.  With all of the "known issues" at release, why didn't they get fixed for that release???

Now I get an SSL error every time I try to log into the server... but only on one of the two computers I have that are SET UP EXACTLY THE SAME WAY!!!

:smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry::smileyangry:

0 Kudos
7 Replies
AishR
VMware Employee
VMware Employee

Please provide the error you are receiving to assist you further

0 Kudos
wedge07
Contributor
Contributor

That's all the error gave.  "SSL error."  This was when I tried to log into the Server.

0 Kudos
HussamRabaya
VMware Employee
VMware Employee

check this file page 13, it explain the issue and how to  solve it

https://docs.vmware.com/en/VMware-Horizon-Client-for-Mac/4.0/horizon-client-mac-document.pdf

0 Kudos
wedge07
Contributor
Contributor

You're kidding me, right?

Let's just go with yeah, you're kidding me.

I'll say this again: two computers... both running the exact same macOS... using the same CAC reader... both configured EXACTLY THE SAME WAY... one logs in with no issues, the other gives the incredibly verbose error: "An SSL error occurred."

Tell me again how reading the TSL/SSL configuration is going to fix the issue.

0 Kudos
TechMassey
Hot Shot
Hot Shot

Quoting Spock, "if all other possibilities have been eliminated. The impossible is the most likely answer."

Meaning that by the very nature that one Mac works and one Mac does not, that the issue is with the Mac. The reason for that, I don't know because the error is vague. However, you can start by process of elimination. Install a different browser.

Please help out! If you find this post helpful and/or the correct answer. Mark it! It helps recgonize contributions to the VMTN community and well me too 🙂
0 Kudos
wedge07
Contributor
Contributor

How will a different browser facilitate a virtualized environment?  What impact would running Safari/Firefox/Chrime have on Horizon?

I’m asking because I don’t think you asked yourself those question before you wrote your response.

0 Kudos
TechMassey
Hot Shot
Hot Shot

Using HTML access to Horizon via a browser would be a quick way to isolate the issue to only the Horizon Client. If however, the browser has the same issue then we can assume its an issue with the Mac OS given that we know the other Mac can connect to Horizon.

If it is isolated to the Horizon Client, I suggest reviewing the logs for any additional information around the error. This is a good VMware KB that lists all log locations including the Horizon Client: VMware Knowledge Base

Please help out! If you find this post helpful and/or the correct answer. Mark it! It helps recgonize contributions to the VMTN community and well me too 🙂
0 Kudos