Users are forcibly logged off on recompose task


We have a weird problem on recompose tasks.

When i schedule a recompose task and choosing "Wait for the user log off" option, after a few hours the users are forcibly logged off somehow even though i chose Wait for the user log off" option.

Although, the "Log off after disconnect" and "Refresh after log off" pool options are set to "Never".

For example:

Recompose task created on 02:00 PM,

All machines with status "Available" or "Provisioned" are getting the task almost immediately (As it should be),

All machines with status "Disconnected" are getting the Recompose task on hold, waiting for the user to log off as it should be, but after a few hours, at 08:00 PM or at 11:00 PM something is forcing those "Disconnected" machines to log off and then they are recomposed.

I looked for schedule tasks on our environment or GPO or anything else that could cause to a log off process but i couldn't find anything.

Of course that this is a very problematic issue because the user experience is impacted.

Any ideas what it could be?


0 Kudos
2 Replies
VMware Employee
VMware Employee

What is the horizon view and agent version?

Does it triggers a logoff after 2hours ONLY when you schedule a recompose? Or it happens in normal day-to-day hours as well?

Do you have any session timeout configured in View admin global settings?

0 Kudos

Hi Shreyskar,
The Horizon and agent versions are 7.10
When i schedule a Recompose task, the disconnected machines are forcibly log off after 6-8 hours.

Until yesterday I had the "Forcibly disconnect users" setting on the Global Admin page set to 20 hours (by minutes) and I saw yesterday on the connection server logs a value that called: "LogOffAfterDisconnectTimeout=1200".

This is the exact amount of time that was configured on the Global Admin page I've mentioned.

From what I understand from this value is that a log off process is happening after 20 hours and not disconnect as I understand from the Global Admin.

This is very confusing setting. Something is wrong here I think.

Yesterday I've changed the "Forcibly disconnect users" setting to Never and I recomposed again. I'll check on Sunday if there is any change for good.


0 Kudos