ZeRoC00L
Enthusiast
Enthusiast

Upgrade Vmware View 4.5 to 4.6

Anyone already done the upgrade of vmware view from 4.5 to 4.6 ?

Can this be done online or should all users logoff ? What will happen with existing running sessions ?

0 Kudos
9 Replies
mittim12
Immortal
Immortal

I haven't done the upgrade yet but the first rule in upgrading the connection brokers is to stop the View connection service on all brokers.  This means that if you are using tunneling I would think the users would be disconnected.  If you are using direct connect then users already connecting should stay connected but any new users would not be able to connect. 

0 Kudos
AndreTheGiant
Immortal
Immortal

See: http://communities.vmware.com/people/AndreTheGiant/blog/2011/02/26/from-view-45-to-view-46

The upgrade is quite fast, but there are two critical moment:

  • Upgrade of the Connection Server: is you have only one you will have the service stopped and restarted. Depending on your configuration you may loose the connection.
  • Pool recomposing: this depends on how you handle this step.

Andre

Andre | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
0 Kudos
pwynne
Contributor
Contributor

Hi,

I have upgraded my 4.5 solution to 4.6 today. I disconnected all users as the services needed to be restarted.

Something to note is that during the upgrade I found that the connection server under Configuration > Servers checked the SSL checkbox under the connection server settings which prevented internal users accessing the desktop sources until i unchecked the box. strange!

Upon completion i rebooted the connection server for a refresh and all internal users connected back in without issue after updating the client.

Where I have had issues is with the security server. I cannot get branch users to access their desktops at present.

I have upgraded the security server to 4.6 and verified broker connectivity. I am still looking at this one

Paul.

0 Kudos
pwynne
Contributor
Contributor

Just thought I would add to my previous post in relation to upgrading View 4.5 to 4.6 while having a Security server in the solution. It took me to this morning to resolve the issue.

post upgrade I could authenticate to the security server and see available desktop sourcse but i could not launch the rdp session. SSL was failing.

The resoultion was to add the following following line to the locked.properties file on the security server in folder

C:\Program Files\VMware\VMware View\Server\sslgateway\conf\locked.properties

serverProtocol=https

restart the connection server and security server and this should resolve the issue.

hope this helps,

paul.

0 Kudos
lefcakis
Contributor
Contributor

I am running 4.6 and I am having a problem discribed here.  I don't have a Locked.Properites file....????

0 Kudos
pwynne
Contributor
Contributor

Hi,

The locked.properties file is located on the security server if you use one in your solution? Are you having issues accessing the desktop pools from inside your network or from the outside?

One thing to check on the connection server is the SSL setting on the Configuration>Servers> Connection server. SSL set or Not.

How far does a failed connection go? can you sucessfully log in and view the available desktop sources?

Paul

0 Kudos
lefcakis
Contributor
Contributor

The problem I am having is that I can't connect to anything since 4.6

We had a security server but we just removed it.

The client will prompt for use name and password. You can then see the desktops your assigned to,but when you try to connect it always says they are unavailable.

Funny thing 1 person is able to connect. Not sure what is different with their setup. Everything was scrubbed and reinstalled this morning. Yet he still connects.

Sent from my iPad

0 Kudos
pwynne
Contributor
Contributor

Hi

That's strange. For me I turned off ssl on the connection server and my internal users could connect. Did you upgrade the security server to version 4.6?

Sent from my iPhone

0 Kudos
pwynne
Contributor
Contributor

My overall fix was :

1. Upgrade the security server to version 4.6 (ensure the connection server can talk to the security server during the upgrade to set the passkey.

2. In the program files\VMware\jre\sslgateway folder edit locked.properties and add the line

Protocol=https ( let me check my server in the morning to ensure this is right)

Paul

Sent from my iPhone

0 Kudos