RotoVegas
Contributor
Contributor

Unified Access Gateway 3.10 Upgrade - Login Issues

Dear all

We've recently upgraded to Horizon 2006 from 7.11. Our UAG appliances have been upgraded from 3.8 to 3.10

Since the upgrade the UAG appliances handling our SSO using Microsoft Azure have started returning the following error for a small number of users:

"Error: User not same as the one in previous screen. Please check it and try again."

It appears to be limited to older Android devices using the Horizon Client App. The same users can successfully login using other devices (e.g. Laptops, PC's or Apple devices).

What we've found is that these older Android devices require the exact capitalisation of the UPN for the user.

For example if the user UPN in Azure is Tony.Stark@mydomain.nz but you log into Horizon using tony.stark@mydomain.nz then the error is returned. If you use the correct capitalisation then it works fine.

Why some older Android devices are doing this we're not sure. We only had this issue when upgrading to UAG 3.10

Posting as an FYI for the community.

Kind regards.

 

 

 

Labels (4)
0 Kudos
2 Replies
fabio1975
Expert
Expert

Ciao

have you tried to update the UAG to version 20.12? 

Fabio 

0 Kudos
RotoVegas
Contributor
Contributor

Hi Fabio

No, we're in the process of migrating our linked clone pools to instant clone so we're unable to upgrade to 20.12 just yet. I understand that UAG 20.12 is compatible with Horizon 20.06 but we'd rather wait and upgrade everything together at the same time.

I'll update the post when we do upgrade and confirm if the issue persists.

Kind regards,
Lane.

 

0 Kudos