Highlighted
Contributor
Contributor

USB microphone not working but receiving audio out

Hi,

I have recently been tasked with looking into using USB headsets on our recently deployed HP T620 Thin Clients.

There seems to be bits and pieces documented about the issues around connecting audio devices through a PCoIP connection but nothing solid.

My initial issue was that the audio I was receiving from another user on the Thin Client was muffled and distorted but they could hear me perfectly on their end.

To solve this issue I installed the Teradici Virtual Audio drivers and updated the ThinPro image on the thin client (which was very outdated).

I thought this may solve the issue I was having with distorted audio, but alas it only reversed it - now I can hear the VM audio perfectly but it is not picking up the microphone input at all.

Any thoughts or recommendations would be appreciated to get this issue solved asap.

Thanks

0 Kudos
7 Replies
Highlighted

Have you verified that you are using RTAV?

0 Kudos
Highlighted
Contributor
Contributor

Can you advise of how I would be able to check this?

or is this a default function that is enabled when using the correct versions of Vmware View that support RTAV?

0 Kudos
Highlighted
VMware Employee
VMware Employee

assuming everything is configured correctly; it is likely that the wrong microphone source is being selected for use. normally the last attached audio device would be used, but, possibly something else was attached more recently or for some reason its picking up the wrong things.

which client are you using - windows?

if so, see my blog post here: Real-Time Audio-Video (RTAV) for Horizon View - VMware End-User Computing Blog - VMware Blogs that talks about how to select the microphone for use with rtav.

also, make sure you are NOT redirecting the usb device into the guest using usb redirection. it needs to be left local to the client.

ping back if you have a specific question or problem that the above doesnt help with,

cheers

peterB

0 Kudos
Highlighted
Contributor
Contributor

Thanks, I think I can see the issue now.

I am running the vmware view client on a HP Thin Client model: T620 which runs HP's own ThinPro OS (which I am pretty sure is a linux variant)

I read in your blog that currently RTAV is only supported on windows clients - is there any plans to get this working on other OS's?

0 Kudos
Highlighted
VMware Employee
VMware Employee

ah. ok. so if its a thin client, you have to check that the vendor has provided a linux client which is recent enough to support RTAV. TBH, we released RTAV around 2 years ago so Im sure you should be ok.

we support rtav on windows, linux, os x.

blog posts are:

Real-Time Audio-Video (RTAV) For Horizon View, Part 2 - VMware End-User Computing Blog - VMware Blog...

Real-Time Audio-Video (RTAV) for Horizon View, Part 3 - VMware End-User Computing Blog - VMware Blog...

cheers

peterB

0 Kudos
Highlighted
Contributor
Contributor

Ok so I have been doing some messing around with the configuration and also looking through various directories on the Linux client.

Personally I do not think i have RTAV installed on the client.

I do have a question though - If I were to get it working how does the microphone show on the VM? Currently I do not have any drivers (even virtual) in my windows recording devices options.

0 Kudos
Highlighted
VMware Employee
VMware Employee

on client side; if it's installed, you would see this file:


/usr/lib/pcoip/vchan_plugins/libmmredir_plugin.so

on the guest side; you need to have the view feature pack installed, and have the Real Time Audio Video feature enabled. you also must be running a PCoIP session.

once installed, you should then see a VMware Virtual Microphone device installed if you look in device manager. The Virtual Audio (dev tap) driver does the audio out (ie what you hear from the guest desktop)

note that the Virtual Audio (DevTap) driver isn't part of the Real Time Audio Video feature and I think is installed by default (or if not, its a separate option)

deviceManager.png

hope that helps,

cheers

peterB

0 Kudos