SRT65
Enthusiast
Enthusiast

USB Redirect via UAG

Jump to solution

Hi All,

I am experiencing an issue whereby USB redirection via VMware Horizon UAG 3.6 does not work. All we get is "USB unavailable". This is using various versions of Horizon Client on Windows and Mac. It works fine when client on same network as the VM desktops. Also works fine via the same UAG using a zero-client but have read that Teradici zero-clients do USB over PCoIP so not the same thing as VMware Client USB redirect.

I have traced the issue down to the TCP:32111 packets. These always appear to be direct connection from the client IP to the agent IP, therefore it works when on the same network however when remote and accessing desktops via UAG the 32111 packets are still trying to get to the agent via its direct local IP address which of course in not accessible remotely. When remote the HTTPS/PCOIP/BLAST packets all go via the UAG except the 32111 packets.

I spent 1.5 hrs on the phone to VMware tech support to a guy that kept insisting that it was a firewall issue at our end despite the fact that I showed him in Wireshark that the 32111 packets were not even trying to go over the Internet but a agents local IP address (not accessible) while the rest of the session data was going over the Internet to the UAG. Eventually I gave up and thought I would try ask here instead and might get more sense.

Has anyone successfully got VMware client USB redirection working over the Internet via a UAG.

VMware Horizon 7.7 connection server

VMware UAG 3.6

VMware Horizon Client 5.4.1

VMware Agent 7.7 on VDI desktops.

Any help would be greatly appreciated.

0 Kudos
1 Solution

Accepted Solutions
SRT65
Enthusiast
Enthusiast

UPDATE:

I worked out that issue was caused by not having "Enable Tunnel" switched on at the UAG Horizon configuration page.

View solution in original post

2 Replies
SRT65
Enthusiast
Enthusiast

UPDATE:

I worked out that issue was caused by not having "Enable Tunnel" switched on at the UAG Horizon configuration page.

BYOB14
Enthusiast
Enthusiast

So we are seeing this intermittently from users WFH on all client versions ranging from 4.6.1 to 5.4.2

Enable Tunnel is on for the UAG

If I access my VM from home on 3 different laptops using 3 different versions of the client I can't get the USB redirection to say anything but USB Unavailable.

Other users working from home, connecting through the UAG are having no issue.

Remotely connect to another PC at the office and then use the 4.6.1 agent to connect - I get the USB Redirection just fine.

0 Kudos