VMware Horizon Community
Claudiocaf
Enthusiast
Enthusiast

[URGENT] View Composer is not provisioning new VMs, or perform Recompse/Refresh tasks...

Hi guys,

I have a very serious problem!!!

I've recomposed some VMs this morning, but suddenly, when trying to refresh another VM, the refresh task was stuck.

I tried to cancel the task, but also that operation was shown in View Manager, but never completed!

I tried to delete the machine... no way! Then I deleted that VM manually (according to VMware KB, without problems).

Waited for a new VM to be provided... nothing happened!

Now, if I want to add new VMs in a pool, if I create a new pool, if I run a recompose/refresh/ecc, nothing happen!

What can I do?

In View Events there's nothing strange!

Panic!... ๐Ÿ˜ƒ

_______

Claudio

Reply
0 Kudos
6 Replies
blakebevard
Enthusiast
Enthusiast

Check the Composer service on the vCenter server.  If this is hung, it can cause problems.  What do you see in vCenter?  Are there any errors there with communication?

Reply
0 Kudos
Linjo
Leadership
Leadership

First, don't panic!

If its a production system that is not working then the first action to take is to take the phone and call VMware Support and work out the problem with them.

// Linjo

Best regards, Linjo Please follow me on twitter: @viewgeek If you find this information useful, please award points for "correct" or "helpful".
Reply
0 Kudos
Claudiocaf
Enthusiast
Enthusiast

Composer service is running, I restarted it, I restarted the vcenter machine also, but it didn't help!

VCenter 4.1

View 4.6

Vcenter has no problems.

Reply
0 Kudos
royberk
Enthusiast
Enthusiast

It seems that if your recompose/refresh was stuck AND you cant provision new VMs in a pool that maybe some communication between VC and View is not occuring.

Did you check to see if some addressing was changed or if you can ping one from the other?

Reply
0 Kudos
Claudiocaf
Enthusiast
Enthusiast

I don't think so, because if I create a new pool, a new folder is created on the vCenter, but no linked clones!

Reply
0 Kudos
Claudiocaf
Enthusiast
Enthusiast

Really strange... this morning everything is working... :smileyshocked:

Reply
0 Kudos