Gezmonder
Enthusiast
Enthusiast

UAG Blast - Failed to resolve proxying route for request

Jump to solution

Hello,

We have had UAG running for a while and it works fine using the full client but there has been a recent requirement for HTML Blast access for external users which does not work fine.

It's been enabled for a while as far as I'm concerned but we never tested it. Authentication works fine and users can see and select their desktop pool, it then takes them to a screen saying "Failed to resolve proxying route for request".

I have downloaded to log bundle but it's not revelaing very much at all. The last entry in the esmanager.log file says "Accessing virtual/rdsh desktop using protocol BLAST with ipAddress x.x.x.x (the connection server). The BG log file really doesn't say anything of note.

HTML access works fine internally if not using the UAG and there are no drops of any traffic on the firewalls. I do have a load balancer in place but I am bypassing that for now and just pointing at a single connection server, it makes no difference though.

Horizon 7.01

UAG 2.9

Cheers.

1 Solution

Accepted Solutions
Gezmonder
Enthusiast
Enthusiast

Sorted this in the end, I logged it with VMWare support:

"Use Blast Secure Gateway for HTML Access to machine" on the Connection Server properties in the Admin console was set to enabled.

I guess that's for Security Server scenarios only.

View solution in original post

6 Replies
markbenson
VMware Employee
VMware Employee

Can you check the Horizon Connection server debug logs and see if you can see any "origin" errors. Search the log for "origin". If you see errors, follow the origin checking documentation e.g. Documentation for VMware Horizon 7 version 7.0

0 Kudos
Gezmonder
Enthusiast
Enthusiast

So this is in C:\ProgramData\VMware\VDM\logs\debug<date><some other number>.txt ?

I can't find the word "origin" in there anywhere.

Also just noticed that the VMWare Horizon View Blast Secure Gateway service was set to manual and not started. Is that required? I started it anyway and it's not made any difference.

I've also just added portalHost=view-gateway.example.com to the locked.properties file but it hasn't helped either.

0 Kudos
Gezmonder
Enthusiast
Enthusiast

Sorted this in the end, I logged it with VMWare support:

"Use Blast Secure Gateway for HTML Access to machine" on the Connection Server properties in the Admin console was set to enabled.

I guess that's for Security Server scenarios only.

View solution in original post

swint
Contributor
Contributor

Thanks. Glad you were able to figure this out. It let me find and resolve the exact same problem on my deployment in just a matter of minutes. Smiley Happy

0 Kudos
Saaditani
Contributor
Contributor

Hello Gezmonder,

I am facing the same problem and I unchecked "Use Blast secure gateway" on the connection server and still gives the same problem and in the url field it gives this error:

r/C2AAA33C-33BE-43B2-92E0-D549EB2859E5/certAccept.html?numPages=1a

horizon 7.4 with UAG 3.2.1

0 Kudos
ITGuy0815
Contributor
Contributor

Thanks!! This was the solution

0 Kudos