Netjim
Contributor
Contributor

Time in Horizon VM takes user's physical machine time

Jump to solution

I have a user who is connecting to a VM that is in a VCenter that is in Eastern Standard Time.

He is in Central Time, and when he logs into the VM, the time reflects Central Time.

This screws up his Outlook, and obviously I want the VM to get it's time from the domain, or ESXi host, but it doesn't.

His VM even says the time source is a domain controller.

I have the ESXi host NTP set, and the VM is set to sync time with the host.

Thoughts as to how to stop the VM from getting Central Time (user's physical machine).

He is connecting via Horizon SSL web.

0 Kudos
1 Solution

Accepted Solutions
LarryBlanco2
Expert
Expert

The time zone sync is the default behavior.   the client will automatically adjust the desktop to the time zone the client is in.  

you can change the default behavior using the gpo.

Using Group Policy Settings to Configure Horizon Client

look  for time zone synchronization.

larry

View solution in original post

7 Replies
sjesse
Leadership
Leadership

Looks like there is a registry setting you can use to disable that time zone sync

[HKEY_LOCAL_MACHINE\Software\VMware, Inc.\VMware VDM\Agent\Configuration]

DisableTimeZoneSynchronization="true"

or there is a group policy.

VMware Knowledge Base

I've never needed to do this, but from what you explained it sounds like this should fix it.

0 Kudos
LarryBlanco2
Expert
Expert

The time zone sync is the default behavior.   the client will automatically adjust the desktop to the time zone the client is in.  

you can change the default behavior using the gpo.

Using Group Policy Settings to Configure Horizon Client

look  for time zone synchronization.

larry

LarryBlanco2
Expert
Expert

its actually 'disable time zone forwarding'

Netjim
Contributor
Contributor

No Group Policy that I can see.

I'll have them try the registry first.

0 Kudos
Netjim
Contributor
Contributor

I added the ADMX into my GPO and edited this setting plus the other (agent setting and computer settings needed).

I will post an update when the end-user is able to verify.

0 Kudos
BenFB
Virtuoso
Virtuoso

The Horizon Client sends it's time zone to the Horizon Agent so the user is presented with their local time in the virtual desktop. This shouldn't have any impact on other applications as it's just a time zone adjustment. If you don't like the behavior it can be disabled as others have pointed out but I suspect something else is wrong.

Have a look at the following registry keys on the virtual desktop with the Horizon Agent. These are populated by the Horizon Client when there is an active session and that is how the timezone is adjusted.

HKEY_CURRENT_USER\Volatile Environment\1\ViewClient_TZID

HKEY_CURRENT_USER\Volatile Environment\1\ViewClient_Windows_Timezone

0 Kudos
Netjim
Contributor
Contributor

After configuring the Group Policy settings the user's VM went back to Eastern Time, which is the desired state.

So it was the "VMware Horizon Client Configuration" ADM setting "Disable time zone fowarding" = Enabled

and

"VMWare View Agent Configuration" ADM setting "Disable Time Zone Syncronization" = Enabled

0 Kudos