scnguye2
Contributor
Contributor

Samsung NC-240 - Windows 7 Connection Issue with VMware View

Jump to solution

Hello all,

My Samsung NC-240 is set to connect to my VMware View Connection Manager server. I can connect to any of my WinXP virtual desktop via PCoIP or RDP just fine, but I cannot connect to my Windows 7 virtual desktop. Each time I try to connect, it will error out and say "Session Lost!"

Looking at the NC-240 Event Log, I see the following:

11d,00:01:09.260> Ready to connect with host

11d,00:01:21.990> Connecting with host (10.3.70.110, 00-00-00-00-00-00)

11d,00:01:22.020> Using resolution 1920 x 1080 at 60 Hz on DVI port 0

11d,00:01:22.150> CONNECTED (10.3.70.110, 00-00-00-00-00-00)

11d,00:01:22.160> Setting host power state to: S0

11d,00:01:22.960> SESSION ACTIVE

11d,00:01:23.600> (MGMT_RDP): Invalid capability length (20)

11d,00:01:23.600> Connection dropped (detected RDP protocol error)

11d,00:01:23.680> Session lost!

11d,00:01:23.680> (MGMT_RDP): INIT: Received unrecognized event 0x20!

Here is the current version info of my NC-240:

Firmware Part Number: FW010034

Hardware Version:

Firmware Version: 3.0

Firmware Build ID: v250

Firmware Build Date: Dec 7 2009 15:55:15

PCoIP Processor Revision: 1.0

Bootloader Version: 2.1

Bootloader Build ID: v163

Bootloader Build Date: Aug 28 2008 16:56:13

Here is the current version info of my VMware View VCM and Agent:

VMware View 4.0.0-210939

I appreciate any input.

Thanks,

Sang

0 Kudos
1 Solution

Accepted Solutions
plizken
Enthusiast
Enthusiast

I think its the same as P20 so try wyse page

View solution in original post

0 Kudos
8 Replies
Vodder
Enthusiast
Enthusiast

Hi, did you manage to resolve this? Exactly the same issue here on the 190 and 240 models when trying to RDP to a Win7 image. Works fine on XP and Vista. Not good when trying to demo it to a client!

@timgleed | VCAP5-DCA/DCD | VCAP4-DCA/DCD | VCP5 | VCP4 | VCP3 | VCP4-DT | VCA4-DT | VTSP4 | MCITP | PRINCE2 | ITIL | BSc Hons
0 Kudos
plizken
Enthusiast
Enthusiast

have you tried to update the firmware to 3.1 i think it is?

0 Kudos
Vodder
Enthusiast
Enthusiast

No I haven't. Do you know where I can obtain it from? Samsung's website only shows a Windows driver. No firmware

@timgleed | VCAP5-DCA/DCD | VCAP4-DCA/DCD | VCP5 | VCP4 | VCP3 | VCP4-DT | VCA4-DT | VTSP4 | MCITP | PRINCE2 | ITIL | BSc Hons
0 Kudos
plizken
Enthusiast
Enthusiast

I think its the same as P20 so try wyse page

0 Kudos
Vodder
Enthusiast
Enthusiast

Excellent - thanks! Notice in the release notes Windows 7 support added in 3.1 Smiley Happy

@timgleed | VCAP5-DCA/DCD | VCAP4-DCA/DCD | VCP5 | VCP4 | VCP3 | VCP4-DT | VCA4-DT | VTSP4 | MCITP | PRINCE2 | ITIL | BSc Hons
0 Kudos
scnguye2
Contributor
Contributor

Just uploaded PCoIP Zero Client firmware 3.1.1, downloaded from Wyse P20 support page to my NC240, here are the results:

RDP connection to Windows 7 VM works!

PCoIP connection to Windows 7 does NOT work (anymore). It used to work with firmware 3.0, but only after the screen flickers several times, then the screen will stabilize.

Multi-monitor display does NOT work with RDP or PCoIP. I have a second 22" monitor connected to the NC240 DVI-in port. I am able to get dual display on XP VM via PCoIP.

Has anyone gotten multi-display to work with Windows 7 VM on the NC240?

0 Kudos
lb1980
Contributor
Contributor

I have an NC190 and it looks like the SVGA 3D driver isn't supported after following Pricie's work around the SVGA II driver works.

0 Kudos