Mathm
Contributor
Contributor

Recomposing VM or pool : Refit operation resync failed

Hi everyone,

I'm having a hard time trying to recompose either an entire pool or a VM in the View Administrator.

The error I'm encountring is : "Provisioning error occurred for Machine xxxxxx : Refit operation resync failed", then the VM stops and i have to power it again via vSphere.

I tried to follow the VMware KB:     Recomposing VMware View pool fails with error: Provisioning error occurred for Machin..., but no luck. My VC_CONFIG_ID is good in my SQL databse, and no change were recently made to my pools.


I've tried to recompose from an old snapshot which used to work : same error.

I've also tried to refresh then recompose, or reboot my View Composer server... same problem.

Please find attached the composer logs for this operation, featuring a FATAL error. I dit not find anything on this error yet...

Thank you in advance for your help.

8 Replies
mittim12
Immortal
Immortal

What happens if you simply remove a machine and allow it to be recreated?

0 Kudos
Mathm
Contributor
Contributor

Hello,

I removed the VM, it was provisionned again up-front, and then I tried to recompose it. Unfortunately it did not work, the error is the same.

Any idea ?

Thanks

0 Kudos
Mathm
Contributor
Contributor

Hello,

Actually, forget what I said, I must have made a mistake yesturday, in fact I can specify my new snapshot as the default image, then delete my VM and allow it to be recreated. This works like a charm.

Only problem is : this manipulation loses the attribution of a user to a specific VM name, which may cause problems on my network (not sure of that).

I won't take any chance, and for the moment, I have to manually assign each user to his correct old VM name after deleting and recreating them. Is there a way I don't think of to avoid this problem ?

Thanks

0 Kudos
HendersonD
Hot Shot
Hot Shot

Did this ever get solved, I am experiencing the same thing. When I recompose it does a few desktops fine and then throws this error. If I remove a desktop it will re-create it fine

0 Kudos
HendersonD
Hot Shot
Hot Shot

I was getting the same error, solved it by going from static to ephemeral binding for view desktops:

Configuring vNetwork Distributed Switch for VMware View » myvirtualcloud.net

0 Kudos
MiroVM
Contributor
Contributor

Hi,

i had the same problem. The root cause was simple in my case - the snapshot i used had a mounted ISO File - that was causing the problem. It was enough to delete the snapshot and create a new one without anything mapped with the parent image

Gaurav_Baghla
VMware Employee
VMware Employee

Erorr in the Composer logs

2013-06-26 08:46:06,252 | 3             | FATAL | Sim.ServiceCore.SimServiceApiImpl - Error: fail to execute web service call: ResyncSviClones

VMware.Sim.CommonLib.Exception.SimVcSubsystemException: Error in the application.

   at VMware.Sim.CommonLib.VcSubsystem.VcSubsystem25.GetVmMoId(String biosUuid)

  

It is an issue with Bios UUId in the Vmx file is different than in Composer Database. Please file a Support Request and we need to change that Manually from the database

Anytime you had an issue with I moved it Copied and if  you  chose I copied it would change the Uuid  anytime in the future make sure to chose I moved it.

Regards Gaurav Baghla Opinions are my own and not the views of my employer. https://twitter.com/garry_14
0 Kudos
Shreyskar
VMware Employee
VMware Employee

This was a known issue in View 7.4 7400497 which has been fixed in View 7.5.1 onwards.

0 Kudos