gunnarb
Expert
Expert

Reboot VCS without session disconnect?

Jump to solution

Is it possible to make it so I can reboot my View Connection Server without causing my client sessions to disconnect?

-Gunnar

Gunnar Berger http://www.gunnarberger.com http://www.endusercomputing.com
0 Kudos
1 Solution

Accepted Solutions
kenhutchinson
Enthusiast
Enthusiast

Right - I've figured this out. The setting is NOT the global setting I referred to. That is purely for the initial connection from view client to server before the session is actually created.

The setting you want is under configuration, servers - edit the server settings at the bottom and tick the enable "direct connections to desktop" tick box. Just tested it with RDP & PCoIP and works a treat. Session stays open if I reboot the connection manager server.

Reno

View solution in original post

0 Kudos
9 Replies
kenhutchinson
Enthusiast
Enthusiast

I believe it depends on whether you are using SSL or direct connections. See the thread I posted yesterday: http://communities.vmware.com/thread/260317?tstart=0

I am using View 4 and by default, RDP connections are set to use an SSL tunnel. This is set in the global settings in View Manager configuration.

I believe if you enable direct connections (untick the use SSL connections checkbox), then the desktop RDP session is created directly between the client and virtual desktop and no longer tunnelled via the connection manager server over SSL. This will then allow you to reboot the connection manager server without interupting live sessions. Obviously no new sessions can be established until connection manager is back up.

Note I haven't tested this yet but it makes sense and I'd see this as a major flaw of the product if this were not so. Unfortunately I won't be able to test for a few days so if you manage to sort it, please confirm it worked.

0 Kudos
gunnarb
Expert
Expert

I should have stated I'm using PCoIP on all sessions. Where woudl I check SSL/Direct Connections?

Gunnar Berger http://www.gunnarberger.com http://www.endusercomputing.com
0 Kudos
kenhutchinson
Enthusiast
Enthusiast

Thats interesting as my understanding of PCoIP is that all PCoIP connections are direct connections by default. Have you actually tried to reboot the connection manager server while having a PCoIP session opened? What was the result?

The setting is in the same place - View Administrator, configuration, global settings, use SSL for client connections - unchecked.

You can find some info on this in the VMware View Architecture Planning Guide on page 39 - Understanding Client Connection. I found the text quite ambiguous though hence the reason I'm also trying to work this out!!

0 Kudos
gunnarb
Expert
Expert

I have multiple clients all running PCoIP. Whenever I reboot the VCS all clients get disconnected. It blows.

Gunnar Berger http://www.gunnarberger.com http://www.endusercomputing.com
0 Kudos
kenhutchinson
Enthusiast
Enthusiast

Right - I've figured this out. The setting is NOT the global setting I referred to. That is purely for the initial connection from view client to server before the session is actually created.

The setting you want is under configuration, servers - edit the server settings at the bottom and tick the enable "direct connections to desktop" tick box. Just tested it with RDP & PCoIP and works a treat. Session stays open if I reboot the connection manager server.

Reno

View solution in original post

0 Kudos
gunnarb
Expert
Expert

You sir are my new best friend! Thanks! These means I don't have to design my VCS with some crazy HA redundancy. Woo Hoo!

Gunnar Berger http://www.gunnarberger.com http://www.endusercomputing.com
0 Kudos
SWCS833
Enthusiast
Enthusiast

Does this break External Access though, from the Security Servers?

0 Kudos
gunnarb
Expert
Expert

Security Server is going to be a completely different animal as they require the connection to be maintained through them. From what I've heard to accomplish what I'm doing and to do a Security Server, I would have to stand up two VCS servers, one for normal internal usage and one for external usage.

I could in all likelyhood be wrong about this but that's what I've picked up on the forum with regard to this. I don't have a SS up yet,once I do I'll test this, but it's not a high priority for me right now.

-Gunnar

Gunnar Berger http://www.gunnarberger.com http://www.endusercomputing.com
0 Kudos
kenhutchinson
Enthusiast
Enthusiast

PCoIP is not supported (yet) in tunneled connections so my understanding is the only way you can use PCoIP for external connectivity is over a VPN. In other words you can't proxy the session via the security server. Again there is some information on this documented on pg 40 of the architecture planning guide.

http://www.vmware.com/pdf/view40_architecture_planning.pdf

0 Kudos