fugrat1
Enthusiast
Enthusiast

Quickprep has wrong time zone

I have 2 Windows 10 gold images for 2 different pools that have had the timezone set to GMT and it shows correctly in these.  When I use these images to create Linked clone pools using quickprep the timezone is changing to -7 Mountain Time.  How can I prevent this happening, or set the correct time zone?  I know it can be done with sysprep but is is possible to set a timezone using quickprep?

0 Kudos
5 Replies
sjesse
Leadership
Leadership

Are you sure its no being overridden by the horizon client since the horizon client can pass that information through.

0 Kudos
vBritinUSA
Hot Shot
Hot Shot

Normally when you connect to the Pool from your device the timezone is synced to that device.

i.e. Horizon POD in Central Time, Client on East Coast. When client connects the TZ is synced to East.

Please mark helpful or correct if my answer resolved your issue.
0 Kudos
fugrat1
Enthusiast
Enthusiast

Hi both

When we connect using the Horizon client it is setting the timezone to GMT.  It is when viewing these machines through vCenter I see the incorrect time.  This also means that any timestamps in logs are in mountain time which is difficult when troubleshooting

0 Kudos
Fernanernie
Contributor
Contributor

I have this very same issue, I have created two pools with the same results.

Horizon 7.9.0 build 13956742

vSphere Client 6.7.0.40000

Win10 Enterprise 1903 desktops.

Log in as the Administrator on "LinkedClone1" to apply rights and time zone is correct (UTC -06:00)

When I log in as the user the time zone settings change to (UTC -7:00) Arizona

In both instances it is stated that the time sync was done from the same DC (ESXIs are pulling from NTP.ORG)

Now I could handle this as I could just write line into a powershell script to correct this as there are a few other configurations that need to be done, BUT if the machine is rebooted it goes back to the (UTC -07:00) Arizona and I really would like to not sweat a powershell script being structurally significant to my envoirnment.

I am not even using quick prep or anything, it is literally a Win10 machine that I built, created a snapshot and pool from.

0 Kudos
Fernanernie
Contributor
Contributor

Just resolved my issue, how are you logging in?

For me it was a 10Zig thin/zero client.  Time Zone on the local device was set to -7.  Changed to the correct one and it is fine now.

0 Kudos