tech001
Enthusiast
Enthusiast

Problem with application pool and the hosted server taskbar

Horizon 6 View 6.2.0 build-3005368

Server 2008 R2 64 bit

So I've created a application pool for Microsoft office applications (2010) and everything looks good. When I try and open anything through the horizon client, it basically logs me onto the server and then opens the application.

pastedImage_0.png

it opens the taskbar above my normal task bar and then I'm basically on the server. I can close the application and navigate on the server as if I RDP into it.

Do anyone have any helpful ideas how to fix this? I don't want the taskbar to show and I don't want my users to log onto the server at all.

Thanks.

0 Kudos
5 Replies
pubudu326
Contributor
Contributor

Hi tech001,

Are you using RDS farm? if you are using RDSH you can publish only the application to the end users. you can  choose your protocols (PCOIP or RDP) which that application want to use over network. Otherwise you can thinapp your application then you don't want to use any server (RDS) and no need to additional license also (RDP). No display task bar these two methods.

If you want to advise regarding the VMware thinapp Please reply via this.

Thank you,

Pubudu.

0 Kudos
tech001
Enthusiast
Enthusiast

Yes I'm using a manual RDS farm with one RDS host. The default protocol is PCoIP. I have an application pool of just notepad and Word. The RDS host just has RDSH installed along with the apps and view agent.

I just want the application published to my users so when they get on the Horizon Client and click the application icon, it just opens it likes it's installed on their computer. I don't want them to be logged on the server and have to deal with the two taskbars.

I'm not wanting ThinApps at this point since these are remote clients not on my network.

0 Kudos
pubudu326
Contributor
Contributor

Hi tech001,

Please follow below steps to create RDHS in VMware. Just Remember This  (Please enable Remote Desktop Service role and Remote desktop session host service under role services)

  1. Install Remote Desktop Session Host service (role) in Windows Server   2012 R2 or 2008 (whatever os used).
  2. Install View Agent in RDS server.
  3. Create RDS Host Farm in View Connection server.

After that go to Application pool and add your application to it. then entitle users to that pool and login via horzon client. then you will be able to see your application that you already added via in application pool. Just double click app and worked. it will run only the application on your computer.

Please update me with your status.

Thank you.

0 Kudos
tech001
Enthusiast
Enthusiast

yes I've already done all that. Thanks for the help, I'm just going to open a ticket.

Thanks again.

0 Kudos
cyphil
Enthusiast
Enthusiast

It seemed this bug is across different Horizon versions / Windows RDS versions. I got the same issue here.

Horizon 7.10, Windows Server 2012R2.

Anyone got hint to fix? Thx.

0 Kudos