Enthusiast
Enthusiast

Pool Creation - Guest Customization - No Domain

Pretty simple scenario here.

Tossing together a quick test environment.

Single ESXi 4.1 host. On Host

Windows 2008 R2 - Running vCenter (4.1) and View Composer (2.5)

Windows 2008 Enterprise (x32) - Running View Server (4.5)

Windows 7 - Gold Master for View. (Agent 4.5)

All the machines are on the same domain, whose credentials I use to log into vCenter and View Admin.

When I attempt to create a link clone pool in the View admin panel, I get to Guest Customization. The domain drop down is blank (instead of the normal domain\user). When you click "Browse" next to AD Container you get the following message:

"Unable to retrieve information from Active Directory for domain null"

Hopefully someone can help square me away! I've a 4.0 set up (vCenter and ESXi) running View 4.5 with a few XP pools with no problems and I can't seem to figure out what the difference might be here.

8 Replies
VMware Employee
VMware Employee

The section titled Configure View Composer Settings for vCenter Server describe how to add a user for View Composer. This can be found starting near the bottom of page 14 in this guide:

http://www.vmware.com/pdf/view45_admin_guide.pdf

Hope that helps!

-Mike

Twitter: @MikeBarnett_
0 Kudos
Contributor
Contributor

Hi xtgmike,

Did you find the solution? I have the same problem. When I create ordinary vm from template (not linked clone), I dont have this issue.

Thanks,

Bruce

0 Kudos
Enthusiast
Enthusiast

I hadn't added the domain, as shown in the documentation above. It was one of a few servers I had built in a few days and zoned on it.

0 Kudos
Contributor
Contributor

I also have this problem when using link-clone...

any advise??

0 Kudos
Contributor
Contributor

you are missing to fill the information of the domain when configuring the view composer.

Go to servers and add there the domain you want to add with the admin and the password, and it will appear when deploying a new pool:)

Contributor
Contributor

In the Vmware View Administrator Console, complete the following:

  • Under View Configuration dropdown, select Servers
  • Select your Vcenter server and click edit
  • Select Edit under "View Composer Server Settings"
  • Under Domains select "Verify Server Information"
  • Add your domain

Hope this helps

Contributor
Contributor

Thanks. Though this is an old post but I would like to point out this solution is actually still works on View 6.0.

My situation is when I am usin VCSA and a standalone View Connection Server.  Guess that's why I have to manually add the domain to View Composer Server Settings.

Thankk you

0 Kudos
Contributor
Contributor

thanks man, you saved my day in year 2020, with Horizon View 7.11

0 Kudos