Highlighted
Contributor
Contributor

Patching Windows 10 Breaks Taskbar (Start Menu, Action Center, Date/Time, etc.)

Jump to solution

See attached graphic that illustrates our problem clearly.

  • PROBLEM:  After Windows Update, all existing users lose functionality of some Taskbar items (Start, Action Center, Date/Time). When clicked, nothing happens.  Microsoft says user profiles not present during Windows Update fail to get updated, causing %Appdata% and TileDataLayer components to not match expected values for updated OS.  This explains why brand new user profiles work fine in the updated OS, while older profiles don't.

  • ENVIRONMENT SUMMARY: VMware Horizon 7.1 with Floating Pool, AppVolumes, UEM, Group Policies, Local Policies and Windows 10 Enterprise (CBB) v.1607.

  • TROUBLESHOOTING:  Fixing the root cause will NOT reverse the damage done to profiles, so whenever we troubleshoot, we need to wipe our writable volumes and start from scratch logging into a fresh, non-customized, older version of the OS.  After profile is created from the OS, we perform a Windows Update on the Golden Image, then recompose, then try logging existing profiles into the updated OS.  If existing profile Tasbar features work after this, then we conclude the problem has been resolved (which is what we thought in June, but it came back after July updates).  Also, not all updates break the Taskbar features; we went months without issue earlier this Spring.  It seems that once any customization/optimization is done, irreversible damage takes place leaving profile that log in vulnerable to breaking during some windows update in the future.  Therefore, we tested not applying any customization; especially the VMware optimization tool.  This corrected the problem, therefore allowing us to successfully update the June MS patch that previously broke profiles, but here we are again with broken taskbars after the July MS Windows Updates of the same Windows feature release (1607).
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Contributor
Contributor

TechGuy129 is our hero!!!!!  Thank you for the speedy suggestions! 

Unfortunately, re-registering the Microsoft.Windows.ShellExperienceHost and Microsoft.Windows.Cortana appX packages did NOT fix the problem for us.  However, adding your exclusion to the snapvol.cfg did.  After your suggestion, we spoke to the VMware tech support rep who worked with VMware engineers originally on this issue (months ago) and he recommended appending exclusions 2 - 4 (below) as well.  Apparently those additional ones (2 - 4) helped to eradicate this same issue months ago but had no positive impact for us now.  It seems that as Microsoft continues to make changes to their OS (e.g. deprecating the TileLayerDatabase) we anticipate needing to append new registry or path locations in the future.

exclude_path=\ProgramData\Microsoft\Windows\AppRepository

exclude_registry=\REGISTRY\MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx
exclude_registry=\REGISTRY\MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\AppReadiness
exclude_registry=\REGISTRY\MACHINE\SOFTWARE\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel

P.S.  To test the above, login to your VM, browse to the following path, append the above, then log-out-log-in - viola!  If this works, then you will need to apply this to everyone's write disks by uploading this change as a zip file into everyone's writable volume to correct this after they all log out/in.

C:\SnapVolumesTemp\MountPoints\.....snapvol.cfg

View solution in original post

0 Kudos
2 Replies
Highlighted
Expert
Expert

This is a common issue with app volumes.

First:

Try re-register the Microsoft.Windows.ShellExperienceHost and Microsoft.Windows.Cortana AppX Packages:

In Powershell:

Get-AppXPackage -Name Microsoft.Windows.ShellExperienceHost | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

Get-AppXPackage -Name Microsoft.Windows.Cortana | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

If that works, you can add those lines to shellstart.bat file  using powershell.exe -command "....."

Secondly:

Also, take a look at this post. it suggests adding

"

Basically, you just need to add this line to the snapvol.cfg on your writable template and/or existing writable:

exclude_path=\ProgramData\Microsoft\Windows\AppRepository

"

Windows 10 Start menu stops working after Windows 10 LTSB 2016 March Cumulative Update

0 Kudos
Highlighted
Contributor
Contributor

TechGuy129 is our hero!!!!!  Thank you for the speedy suggestions! 

Unfortunately, re-registering the Microsoft.Windows.ShellExperienceHost and Microsoft.Windows.Cortana appX packages did NOT fix the problem for us.  However, adding your exclusion to the snapvol.cfg did.  After your suggestion, we spoke to the VMware tech support rep who worked with VMware engineers originally on this issue (months ago) and he recommended appending exclusions 2 - 4 (below) as well.  Apparently those additional ones (2 - 4) helped to eradicate this same issue months ago but had no positive impact for us now.  It seems that as Microsoft continues to make changes to their OS (e.g. deprecating the TileLayerDatabase) we anticipate needing to append new registry or path locations in the future.

exclude_path=\ProgramData\Microsoft\Windows\AppRepository

exclude_registry=\REGISTRY\MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx
exclude_registry=\REGISTRY\MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\AppReadiness
exclude_registry=\REGISTRY\MACHINE\SOFTWARE\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel

P.S.  To test the above, login to your VM, browse to the following path, append the above, then log-out-log-in - viola!  If this works, then you will need to apply this to everyone's write disks by uploading this change as a zip file into everyone's writable volume to correct this after they all log out/in.

C:\SnapVolumesTemp\MountPoints\.....snapvol.cfg

View solution in original post

0 Kudos