continuum
Immortal
Immortal

Operating system not supported

I try to connect to a View Portal but get this error - what can be the reason ?

___________________________________

description of vmx-parameters:

VMware-liveCD:


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos
14 Replies
Troy_Clavell
Immortal
Immortal

what OS are you running while trying to connect to the portal?

0 Kudos
mittim12
Immortal
Immortal

That means that the client piece of the View environment is not supported on your OS. All of the supported operating systems are on page 16 of the link below.

http://www.vmware.com/pdf/viewmanager3_admin_guide.pdf

If you found this or any other post helpful please consider the use of the Helpful/Correct buttons to award points

0 Kudos
continuum
Immortal
Immortal

Hmm - I can't make head or tail of that list ???

I am running 2003-sp2 and the View-client 3.0.1 installed fine.

Should I be able to connect via the View-client then ?

___________________________________

description of vmx-parameters:

VMware-liveCD:


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos
Troy_Clavell
Immortal
Immortal

that won't work... page 18 has supported guest os for Portal connections.

0 Kudos
Troy_Clavell
Immortal
Immortal

you could alwasy deploy and XP or Vista VM and install the client there. That way you can connect through the portal or connect with the client.

If else fails uninstall the gina from the view agent and connect using standard RDP

continuum
Immortal
Immortal

using XP or Vista is no option - actually I use a 2k3-sp2 LiveCD and changing OS is not trivial Smiley Wink

Does anybody know what exactly the browser is looking for when identifying the current OS ?

Maybe I can tell the browser to identify as XP ?

___________________________________

description of vmx-parameters:

VMware-liveCD:


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos
mittim12
Immortal
Immortal

In this thread, http://communities.vmware.com/message/1185401#1185401, they say launching it via a bat file in compatibility mode works.

If you found this or any other post helpful please consider the use of the Helpful/Correct buttons to award points

continuum
Immortal
Immortal

Problem solved - thank you guys

Actually there never was a problem - the View-client worked all the times . It just needed a friendly MOA-user to actually test it Smiley Wink

So the pdf does not tell the full story when it says 2k3-sp2 not supported - on a LiveCD it works

screenshot here

http://sanbarrow.com/moa24/screenshots/moa-view.png

___________________________________

description of vmx-parameters:

VMware-liveCD:


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos
admin
Immortal
Immortal

Check this registry key: http://HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\User Agent

And compare a Windows XP system to your 2K3 box.

Regards,

Chris

0 Kudos
continuum
Immortal
Immortal

Hi Chris

i do not have that key at all - should i populate it so that my system looks like an XP ?

___________________________________

description of vmx-parameters:

VMware-liveCD:


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos
admin
Immortal
Immortal

Mh..... just check the XP system if the key is in there...

0 Kudos
continuum
Immortal
Immortal

I just checked a XP-sp2 and it doesn't have that key either.

A regular 2k3-sp2 has this ke and here it looks like




Windows Registry Editor Version 5.00

[http://HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\User Agent]

[http://HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\User Agent\Post Platform]
".NET CLR 1.1.4322"=""
".NET CLR 2.0.50727"=""
".NET CLR 3.0.04506.648"=""

As this is a LiveCD I can actually populate that key with whatever suits best.

Do you any suggestions ?

Thank you

___________________________________

description of vmx-parameters:

VMware-liveCD:


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos
admin
Immortal
Immortal

I don't know if it works but you could try to add some string values:

"UA-Language"="JavaScript"

"Platform"="Windows NT 5.1"

"Version"="MSIE 6.0"

"Compatible"="compatible"

@="Mozilla/4.0"

0 Kudos
continuum
Immortal
Immortal

You mean like this

 Windows Registry Editor Version 5.00

[http://HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\User Agent|http://HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\User Agent]

[http://HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\User Agent\Post Platform|http://HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\User Agent\Post Platform]
".NET CLR 1.1.4322"=""
".NET CLR 2.0.50727"=""
".NET CLR 3.0.04506.648"=""
"UA-Language"="JavaScript"
"Platform"="Windows NT 5.1"
"Version"="MSIE 6.0"
"Compatible"="Compatible"

Not sure about syntax for the last one ?

Thank you - very useful.

I'll ask the friendly MOA tester to try as soon as he's back to work Smiley Wink

Grrr - I wish I could simply test this myself Smiley Sad

___________________________________

description of vmx-parameters:

VMware-liveCD:


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos