JohnTwilley
Hot Shot
Hot Shot

Network Status: No Internet Access in Windows 10

Jump to solution

I'm struggling with the following issue, and wanted to know if anyone has run across it.

Windows 1809 VMs (Optimized using VMware Optimization Tool)

VMs are completely accessible, but users complain that Skype and other Microsoft apps don't work. Turns out the OS thinks it has "No Internet Access".  You  can browse the web perfectly.

I'd read that the Network Location Awareness service handles this particular function, and that service is running fine.

Any ideas?

NoInternetAccess.jpg

1 Solution

Accepted Solutions
JohnTwilley
Hot Shot
Hot Shot

OK.  I'll answer my own question.  LOL

As usual, VMware OS Optimization Tool broke this... A new template created this "Issue".

Here the Fix that was posted in the Fling Comments section

"For anyone that runs this and gets "No Internet" and/or Outlook complains about no internet -

One of the optimizations is to disable NCSI, you will need to set the local policy back to Not Configured to fix this. Settings GPO won't override the locally set gpo.

Computer Configuration->Policies->Administrative Templates->System->Internet Communication Management->Internet Communication Settings->Turn off Windows Network Connectivity Status Indicator active tests. – This must be set to Not Configured (or disabled)"

You may have to clear the reg entries at:

HKLM\Software\Policies\Microsoft\Windows\NetworkConnectivityStatusIndicator

Problem Solved!!

Note that one of the VMware guys said the following:

"We don't really want to re-enable NCSI as there is a benefit to disabling it.

We have added an extra setting to address this to the Windows 10 templates (update available through public templates and this will be included in the next release. (Whatever that version is)

Group policy - Do not show the 'local access only' Network Icon
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Network Connections\NC_DoNotShowLocalOnlyIcon = 1

I just tested this with WIn10 1909 with Outlook 209, spun up an instant clone pool and it all worked as expected."

View solution in original post

2 Replies
JohnTwilley
Hot Shot
Hot Shot

OK.  I'll answer my own question.  LOL

As usual, VMware OS Optimization Tool broke this... A new template created this "Issue".

Here the Fix that was posted in the Fling Comments section

"For anyone that runs this and gets "No Internet" and/or Outlook complains about no internet -

One of the optimizations is to disable NCSI, you will need to set the local policy back to Not Configured to fix this. Settings GPO won't override the locally set gpo.

Computer Configuration->Policies->Administrative Templates->System->Internet Communication Management->Internet Communication Settings->Turn off Windows Network Connectivity Status Indicator active tests. – This must be set to Not Configured (or disabled)"

You may have to clear the reg entries at:

HKLM\Software\Policies\Microsoft\Windows\NetworkConnectivityStatusIndicator

Problem Solved!!

Note that one of the VMware guys said the following:

"We don't really want to re-enable NCSI as there is a benefit to disabling it.

We have added an extra setting to address this to the Windows 10 templates (update available through public templates and this will be included in the next release. (Whatever that version is)

Group policy - Do not show the 'local access only' Network Icon
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Network Connections\NC_DoNotShowLocalOnlyIcon = 1

I just tested this with WIn10 1909 with Outlook 209, spun up an instant clone pool and it all worked as expected."

View solution in original post

KeithOvo
Contributor
Contributor

You may have to clear the reg entries at:

HKLM\Software\Policies\Microsoft\Windows\NetworkConnectivityStatusIndicator

it works for me!! thanks~:smileylaugh: