Highlighted
Enthusiast
Enthusiast

Mysterious Console Sessions

HorizonPool.jpgHorizon 7.11 - Automatic Linked Clone Pool - Windows 10 1909

I previously posted this but I had no discussion at all, and maybe because it sounds crazy or was not understood, so this time I am including an image, becasue  a picture is worth a thousand words! Notice in the pic, there are four console sessions to various desktops. They are all from the local administrator, and all were started at the same time. I have no idea what causes this. No one is using the console for these desktops. The console is only used to login to the golden image. The only way to get rid of these sessions are to restart the desktop. Logging off the user is not available for these.  When I look back through the event logs for this date, I can only see the last time that I restarted the machines in order to kill the sessions. The start of these sessions is not recorded in the event log, but they occur a few hours after I restart the machines. I am going to reboot these this evening. I am pretty sure they will be re-connected tomorrow.

0 Kudos
5 Replies
Highlighted
Enthusiast
Enthusiast

Okay, this time after I restarted them they reconnected to the console right away.

0 Kudos
Highlighted
User Moderator
User Moderator

If you followed the techzon article I think the administrator account is passwordless and set to autologon. If so try to set a password and disable that autologin

https://www.securicy.com/blog/how-to-disable-automatic-login-in-windows-10/

Highlighted
Enthusiast
Enthusiast

sjesse, my apologies, don't know if you saw my incorrect answer to your suggestion but I deleted it. Yes, I follow the techzone doc and on this pool the local admin account does not require a password, although when you open a console session to one of the VM's it does prompt for a password, but you leave it blank and click to logon. So it is not really automatic login for the VM's, but it is for the master image. So setting a password might very well stop these rogue console sessions, but I just opened a ticket with VMWare so I am not going to make any changes until they look at it. I'll reprot my finding back here.

Thanks

0 Kudos
Highlighted
User Moderator
User Moderator

No worries, I generally set a password after I rebuild a template, so that may help as I haven't noticed it and haven't seen a lot of people mentioning it either.

0 Kudos
Highlighted
Enthusiast
Enthusiast

Yes, good idea. It is strange though I have a couple other pools with images built the same way but they do not have this strange issue with the console sessions.

0 Kudos