VMware Horizon Community
vrvm
Contributor
Contributor

Logout Problems Windows 10 1607

Hello everyone!

I'm having a Problem with the logout from windows 10 1607 vdi.

If the user take a logout from the windows 10 vdi, the status in view administrator stays to connected, after a few minutes it change to disconnected. The user can't logon again till I delete the desktop.

We're currently use Horizon View 6.2.2. The Windows 10 desktops with the anniversary update has got x64 with 4 GB RAM.

Someone got an idea why the users are not cleanly logout of the session?

Thanks to all for your help.

Greetings vrvm

10 Replies
Smoke14
Hot Shot
Hot Shot

Does this happen with the Web, Native or both clients?

Mike_A
0 Kudos
TitoDz
Enthusiast
Enthusiast

Hi,

I am also running into this issue with Windows 10 Anniversary edition. My VMware Horizon View version is 7.0.1. Both native and web clients are affected. I do notice that View 7.0.2 officially supports Windows 10 Anniversary edition. Maybe an upgrade of View fixes this problem. I will update this post when I perform my test.

"Windows 10 64-bit and 32-bit Anniversary Update; Fresh installation only; Tech preview only; Build 1607. Upgrade is not supported"

In the meantime, you can roll back your Windows 10 Parent to a previous build until this is figured out.

0 Kudos
DavidPatrick
Enthusiast
Enthusiast

I am also experiencing issues with logging out of Windows 10 release 1607, shows up as disconnected in the view management console.

We are running the following, View Horizon 7.02 and agent 7.02.

Any help would be appreciated. Cheers David.

0 Kudos
TitoDz
Enthusiast
Enthusiast

Just to follow up on my last post...I can confirm that yes, this problem still occurs in Horizon View 7.0.2.

0 Kudos
Smoke14
Hot Shot
Hot Shot

Did you build your master image from the Win10 v1607 ISO? If not, try that and see if you get the same results.

Mike_A
0 Kudos
DavidPatrick
Enthusiast
Enthusiast

Update - we have been able to fix the issues experienced.

  • you will need to uninstalled the agent 7.02 and then reboot the virtual machine.
  • next you will need to re-install the agent and check the agent components.

Virtual machine details: upgraded Windows 10 Enterprise x64 1511 to 1607.

Hope this helps.

0 Kudos
TitoDz
Enthusiast
Enthusiast

This worked for me. Thanks!

-Rob

0 Kudos
Justin_Y
Enthusiast
Enthusiast

Not sure what you are describing with check the agent components. Do you just mean to check the options you need to install the agent. I am seeing a similar issue but the desktop cuts out as soon as i select logoff if the users have things open that need to save they are not given the opportunity to save them and then can't log back on with Horizon and it must be deleted. We currently have the logoff button in windows disabled as a temporary workaround.

0 Kudos
BigGeorge
Contributor
Contributor

I'm facing the same issue: when user select "logout" from start menu the client will be disconnect, but the session still remain "connected".

If I try to connect with VMware vSphere Console I see the desktop and the start menu open (as the "logoff" button newer was clicked).

This something (not every time: I need more investigations) happens if the user select "power off".

I've disabled the logoff button from GPO in order to reduce the issue.

My conf:

VMware Horizon View components 7.3.1

Windows 10 Enterprise LTSB 1607 build 14393.1794

0 Kudos
Justin_Y
Enthusiast
Enthusiast

I reported this to VMware Engineering, This is specific to Blast if you use PCOIP it will work as expected. You will only see it hang if you have open applications and click logoff/ restart/ shutdown from the OS. If you watch the desktop in console it will get the prompt that applications were not saved and need to close then will fail back to your desktop. Horizon has allready dropped off so the users doesn't see any of this and it shows as connected, I hoped they would fix this but we are still on 7.1

Here are my notes in forcing windows to logoff by updating your base image.

Navigate to
HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControl.

Open WaitToKillServiceTimeout.

Set the value to 2000 and click Ok. This is the amount of
time, in milliseconds, that Windows waits to kill an unresponsive service. Most
sites recommend you set this no lower than 2000 so that the system has some
time to shut these processes without causing a problem.

*Load Default Profile Registry Hive

Navigate to HKEY_CURRENT_USERControl PanelDesktop.

Create a String Value and name it WaitToKillAppTimeOut. You
can create a string value by right-clicking in the right pane and selecting New
> String Value.

Open WaitToKillAppTimeOut and set it to 2000.

Create a String Value called HungAppTimeout and set it to
2000.

Create
another Sting Called AutoEndTasks and set it to 1.

Had
to add same string to add
HKEY_USERS\.DEFAULT\Control
Panel\Desktop

Create
another String Called AutoEndTasks and set it to 1.

0 Kudos