VMware Horizon Community
Hot Shot
Hot Shot

How to disable a Horizon Client Hot-Key

Hi there,

we have the situation that when connected from Windows to a Linux VDI,

and within that VDI session we need the ShortCut Ctrl-ALT,

but this Hot-Key-combination is intercepted by the Horizon Windows Client.

Is there any possibility to disable the HotKey (ctrl-alt) on the windows side so that it´s not intercepted anymore?



ps: Award points if you find answers helpful. Thanks.
0 Kudos
2 Replies
VMware Employee
VMware Employee


Make sure you are running latest windows horizon client 5.4.2.

By default, ctrl+Alt releases the mouse control so that it is no longer inside the VDI. I understand you just want to disable this and make sure the command is sent inside Linux VDI.

> You should be able to achieve it using windows horizon client GPO (General Settings for Client GPOs ).

Enable 'HotKey combination to grab input focus' policy as below:



> Also make sure the very next policy "Hotkey combination to release input focus" is not enabled for ctrl+alt.

> If the windows client machines are not in domain, you can apply below registry on the client machine and see if it helps:

Registry Hive    HKEY_CURRENT_USER

Registry Path    Software\Policies\VMware, Inc.\VMware VDM\Client\RDP Settings

Value Name    KeyboardHookMode

Value Type    REG_DWORD

Value    2

A value 2 means key combinations are applied to remote machine. (IMsRdpClientSecuredSettings KeyboardHookMode property - Win32 apps | Microsoft Docs )


Good day, Shreyskar.

Is your answer still accurate? I've tried to create aforementioned registry key, but unfortunately it had no effect: my mouse focus was still being stolen as soon as I press Ctrl+Alt.

I'm using Horizon Client v8.2.0 and connecting to remote host using Blast as a transport.


0 Kudos