Stockcoll
Contributor
Contributor

How can I use the CD Rom drive using PCoIP?

We have a non persistent desktop pool using View 4 with PCoIP as the protocol. We are hoping to roll these out across a campus but I have realized the CD Rom drive on the cloned VM's does not seem to work. Is this another issue with PCoIP or is there something that should be set on the Parent VM to allow this to work?

0 Kudos
3 Replies
PaulSvirin
Expert
Expert

I think this link will be helpful for you:

Or you can also use the remote CDROM using RocketDivision StarBurn SDK:

---

iSCSI SAN software

http://www.starwindsoftware.com

--- iSCSI SAN software http://www.starwindsoftware.com
0 Kudos
Stockcoll
Contributor
Contributor

Hi Paul,

Thanks for that. However, I may not have worded my post correctly as I didn't mean that I have a hardware issue I just cannot read a CD\DVD from within my View client session on a VM. I put the DVD into the physical PC whilst logged in to the View Client but when I try to explore the contents of the DVD it says there is no disk in the drive. I have tried this on several different PC models using PCoIP as my protocol but still cannot get the the CD Drive to work within the Virtual Desktop session.

Regards,

Steve

0 Kudos
btdrew
Contributor
Contributor

I see you didn't get a reply. Although your post was a while ago. I'm facing the same thing today. View 4 with XP vms and XP PCs. Through trial and error I am able to read CD/DVDs in the PC through the VM. Here's what to do. In vCenter, power down the VM. Then remove any existing CD. Once done go back in and add a CD. Make it physical, then client CD, the Passive IDE and make the the IDE address 1:0 - the default is 0:1 or 0:0. Mkae it 1:0. Power up VM. Now, still in VC, with the VM highlighted on the left, see the button on top called "Connect CD/DVD". Click it and you'll be able to add D:, E: or F:. Select D:. Interestingly, if you have the VM opened up while doing those last steps, open up VMware Tools and the Devices tab. The IDE box will be unselected but when you click the "Connect CD/DVD" button and select d: after a second or 2 the IDE box will auto-select. Once it does you can read the CD/DVD. I've got mine working this way now. Remaining problem is that this access is not persistent across reboots. My options in View for "connected" or "connect at power on" are greyed out. Still working on that. Hope this helps and if anyone reads this has any ideas abou the greyed out options I'd appreciate hearing from you.

0 Kudos