elchoriz0
Contributor
Contributor

Horizon retro-compatibility

Jump to solution

Hello,

We're actually using Horizon View 6.1 on ESX and vCenter 6.0. We plan to upgrade our golden image/template, actually on Win7 to Win10. Based on VMware Product Interoperability Matrices we can upgrade our Horizon servers to 7.10.1 without upgrading vCenter and ESX. My questions are :

- Does that plan sounds good to you ? :smileyconfused:

- What is the correct upgrade path to reach this version ? I dont understand this page : VMware Product Interoperability Matrices

- After upgrading Horizon from 6.1 to 7.10.1, will the View Agents be retro-compatible ? That way we can migrate the users easily and not all in same time.

I asked the support of course, they said that normally View Agents are retro-compatible but its not recommended. If someone had a similar situation, with or without issues post your answer below.

Thanks you.

1 Solution

Accepted Solutions
Shreyskar
VMware Employee
VMware Employee

Yes. It will however make sure you don't replicate your horizon 7 server with horizon 6 server.

View solution in original post

5 Replies
Shreyskar
VMware Employee
VMware Employee

Hi elchoriz0

First of all check the upgrade path from 6.1 to 7.10.1. Per below doc, direct upgrade from 6.1 to 7.10 is not compatible. Instead you can first go to 7.8 and then to 7.10:

VMware Product Interoperability Matrices

Second check if 7.10 is compatible with your current vcenter and esxi hosts versions.Check the link below, it is compatible with vcenter 6.0.0 and above:

VMware Product Interoperability Matrices

Next if you have any thinclient or zeroclient in your environment, make sure they are compatible with horizon 7.10.1 prior to upgrade:

https://www.vmware.com/resources/compatibility/pdf/vi_view_guide.pdf

Then perform the upgrade as per below guide:

https://docs.vmware.com/en/VMware-Horizon-7/7.8/horizon-upgrades.pdf

https://docs.vmware.com/en/VMware-Horizon-7/7.10/horizon-upgrades.pdf

Regarding agent compatibility, it is backward and forward compatible upto 1 version. So if you are running 7.10 connection server, you can install 7.9 or 7.11 agent. However it is always recommended to use same connection server and view agent versions unless told by vmware support.

elchoriz0
Contributor
Contributor

Hello,

Thank you for answer, it help me a lot ! :smileyplus: :smileyplus:

So that mean, regarding your last sentence, while migrating users, View Agents 6.1 and View Agent 7.10.1 can be run together ?

0 Kudos
Shreyskar
VMware Employee
VMware Employee

Hi elchoriz0

No View 6.1 can not run with View server 7.10.1. You need to migrate all servers as well as view agent in one go.

0 Kudos
elchoriz0
Contributor
Contributor

Hello,

Thank you for this answer.

So, knowing this, would installing a second Horizon 7 server work ? On the same vCenter ? This way I can migrate easily my users 1 by 1...

0 Kudos
Shreyskar
VMware Employee
VMware Employee

Yes. It will however make sure you don't replicate your horizon 7 server with horizon 6 server.